Edit Object actuator, replace mesh
Closed, DuplicatePublic

Description

System Information
WIndows 7, 2.4ghz celeron cpu, 2gb ram, Geforce8400GS

Blender Version
worked 2.69
broken 2.7

Short description of error
Edit Object actuator, replace mesh function doesn't work in blender 2.7. It isn't changing the graphical representation of the mesh.

Exact steps for others to reproduce the error

Again I am unable to upload my blend file because of a size limit. I'll try to create a smaller project with this issue and upload it at a later time.

Details

Type
Bug

I can't reproduce this bug. For me it is working correctly. (windows 7 64 bits)
I attach a .blend to can check the replace mesh functionality.

P.S. regarding replace mesh I have the issue that only replace the mesh but not the material. This issue is tracked in bug T39053.

I meant the material is not being swapped. I guess I should have explained it that way. I have included my blend file. Thanks for the clarification.

I can reproduce it here.
The mesh changes, but not the material, though the material of the obect is linked to the mesh-datablock. The cube should turn blue.

This should be merged with T39053 i reckon.

I wonder if this is linked with the LOD…

hi
I have the same problem
Blender Version
worked 2.69
broken 2.7

System Information
Linux : openSUSE 12.3 x86_64 , 2.1 GHz Core i3, 8gb ram, ATI 6770m

Mitchell Stokes (moguri) closed this task as a duplicate.Apr 14 2014, 11:40 PM

✘ Merged into T39053.