Page MenuHome

avutil-51.dll and libiconv-2 Missing from Windows builds
Closed, InvalidPublic

Description

OS:
Win7 x64 Nvidia gt640

Blender Version
Broken: (2.7

I downloaded and unzipped the package from buildbot and went to run it.

It wouldn't start.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

You could at the very least specify which version of Blender package you downloaded (VC2008 or VC2013)?

Latest build "blender-2.70-b64bdb2-win64" gives me the same message "avutil-51.dll is missing", "blender-2.70-b64bdb2-win64-vc12" starts ok.
"blender-2.70-b64bdb2-win32" and "blender-2.70-b64bdb2-win32-vc12" do not start and gives message "libiconv-2.dll is missing".
Tryed on win8x64 and win7x64

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

It was BLender version 2.70-e9d733a-win64

Same problem in b64bdb2 with 64b, but in 32b I have missing error libiconv-2.dll

reporting it there as my bug report was merged in this one

missing libiconv-2.dll and avutil-51.dll on blender-2.70-b64bdb2-win32
blender-2.70-a7242c3-win32 was working without problem and didn't had those files.

That said, i was looking at the commits list and noticed the presence of avutil-51.dll on the modified files of this entry from a couple of days ago :
https://developer.blender.org/rBd3a73d0845834801608e8d47f372851973724e2c

And noticed Sergey mentionning :
"Libraries are still being committed to the svn, so compilation might be broken
for a while. Sorry for this, but can't really be avoided."

Could this be the reason of those missing dll error ?

Bastien Montagne (mont29) renamed this task from avutil-51.dll Missing to avutil-51.dll and libiconv-2 Missing from Windows builds.Apr 1 2014, 9:24 AM

I just downloaded and tried blender-2.70-1bd3922-win32 from the buildbot and it does not throw anymore the missing dll message, it works great.

I can't confirm for the win64 version as i don't have a 64bits system.

Yes, I have installed blender-2.70-1bd3922-win32 and it works fine. I have not tested the 64 bits built since it is a few days ago.

To whom it may concern, here on Win7 Pro 64bit and Blender 2.70 (Hash: 3216e4b), blender-2.70-3216e4b-win64.zip just downloaded from builder.blender.org/download/ everything works fine and no missing DLLs error messages. So, perhaps, this bug report ticket might be closed.

Bastien Montagne (mont29) closed this task as Resolved.Apr 11 2014, 6:58 PM

Indeed, this has been fixed now! :)

Sanc Tuary (sanctuary) reopened this task as Open.Apr 15 2014, 6:14 AM

And it's broken again starting with the latest build bot i just tried :
blender-2.70-3cf39fc-win32

That popup the same error message about the same missing dll

It was working on yesterday's buildbot without error :
blender-2.70-6e9c2d0-win32

I'm not sure if anyone is still checking this report but the win32 is still missing the dll in
blender-2.70-36defb7-win32

win32 buildbot version is still broken, same missing dll with today's blender-2.70-3442a65-win32

Martijn, can you please check this? Thanks.

@Bastien Montagne (mont29) To me it seems that only the msvc 2008 windows 32 bit version is broken in this regard.

Yes, i just tried the blender-2.70-36defb7-win32-vc12 from the buildbot ( that is older as it is the 19 april , while the vc2008 version that is newer is broken since the 14 or 15 april ) and it works without the missing dll error message.

As the win32 vc2012 is now up to date on the buildbot, i could then give a test to today's blender-2.70-1e39046-win32-vc12
And it worked without a problem , no missing dll message.

I gave a try to the vc2008 version (as it's today built on the same revision), blender-2.70-1e39046-win32 and there's still missing dll for this one.

It confirms only the vc2008 version of the win32 buildbot is missing those 2 dll.
last version of the vc2008 build (from the buildbot i mean) that worked without the missing dll message was
blender-2.70-6e9c2d0-win32 from the 14 april

I know you guys are dropping vs2008 builds , but just for completion of this bug report in case it popup one day on future builds i found out that :

  • latest vs2008 buildbot win32 " blender-2.70-d964bad-win32.zip " has still the missing libiconv-2.dll missing
  • latest vs2012 buildbot win32 " blender-2.70-d964bad-win32-vc12 " does not have such message
  • in the vs2008 buildbot win32 directory if you rename

iconv.dll
into
libiconv-2.dll

there is no error message anymore and the vs2008 win32 build will work perfectly.

Hey Guys,

i've got the same problem.
I downloaded the Win 32bit 5db81a0 build today (2014/05/12) and also got the libiconv-2.dll is missing.
Would be great if it would be fixed soon.
BTW does anyone know if the builds from graphicall.org work?

NG

Current buildbot does not have the problem. And we are moving towards msvc 2013 anyway

Sanc Tuary (sanctuary) reopened this task as Open.Jun 8 2014, 11:43 AM

I know you guys are moving away from it the "legacy" version but it looks like it's just back at that error again

today's buildbot :
blender-2.70-f8f25c3-win32-vc9
claims it's missing libiconv-2.dll again

making a copy of iconv.dll and renaming that copy into libiconv-2.dll solves the problem for those interested

previous version that was on buildbot (and lots before it :
blender-2.70-edfd989-win32-vc9
was working without that error

Thomas Dinges (dingto) closed this task as Invalid.Jun 8 2014, 12:44 PM

Please simply download the official builds, the legacy ones are mainly there as reference still (for bughunting etc).

No need to re-open this report, especially since there is an easy workaround.

from the dev meeting you certainly followed :

"Sergey Sharybin: two regressions were assigned to him, he will look into that. One is related to the switch from MSVC 2008 to 2013 (where OpenMP threading differs). This makes Blender factors slower for Windows users... "

That's reason enough to keep using the "legacy" msvc2008 version until the slow problem affecting the window msvc2013 and openmp is solved