Page MenuHome

mac mouse problem
Closed, ArchivedPublic

Description

System Information
OsX maverick on MacBook pro retina 15", NVIDIA GT650M

Blender Version
Broken: 2.70 19e627c

Short description of error
when i connect the mouse and try to rotate, translate or scale an object the mouse do random movement. This doesn't happe with trackpad. I have tried with other mouse but the problem isn't solved

Video of bug

Details

Type
Bug

Event Timeline

andrea benfa (benfa94) created this task.
andrea benfa (benfa94) raised the priority of this task from to Needs Triage by Developer.

it's similar problem but i have this problem when i select an object and i move the mouse to scalar, traslate, rotate the object

Hmm, what kind of Mouse are you using? I have no issues with older A1197 Mac mouse and mbpr 15 late 2014 and bfe29e0.

I encounter a bit lagging with my wacom too since Mavericks ( OSX 10.9 ), the orig. mouse or
trackpad is fine. I think this is due changed priorities for drivers. Aka: system supported devices work fine,
devices that use third party derivers may suffer under higher cpu loads.

This was never happening before with same setup, so seems a 10.9/outdated 3rd party driver problem.

Possible solutions:

  • use Apple device aka direct supported
  • look for OSX certified drivers for your device

Jens

Sergey Sharybin (sergey) closed this task as Archived.Apr 10 2014, 7:47 PM
Sergey Sharybin (sergey) claimed this task.

Well, sounds like it's not solvable from the blender side. Sorry! This OSes and drivers are always PITA :(