Page MenuHome

Keyframing off Animated property of a rigid body causing it not to be animated at all
Closed, InvalidPublic

Description

System Information
OS: Ubuntu 13.10
Linux kernel: 3.11.0-18-generic

Blender Version
Broken: blender-2.70-b64bdb2-linux-glibc211-x86_64

Short description of error

In this .blend file, keyframing off the Animated property of a rigid body (found in Properties window -> Physics context -> Rigid Body panel), is causing object to reset to original position and not undergo any physics simulation.

Exact steps for others to reproduce the error
I was unable to reproduce the error from scratch. But if you open the .blend file below and scrub through the first 10 frames you will see that at frame 6, when Animated is disabled, it returns to original position.

File:

Details

Type
Bug

Event Timeline

Garrett (Garrett) raised the priority of this task from to Needs Triage by Developer.
Garrett (Garrett) updated the task description. (Show Details)
Garrett (Garrett) added a project: BF Blender.
Garrett (Garrett) set Type to Bug.
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Mar 30 2014, 6:24 PM

@Garrett (Garrett):
It seems thst your rigid body world doesn't have a group assigned.
Try selecting "RigidBodyWorld" as the simulation group and things should work.

Thanks! That solves my problem, although it still seems like surprising behaviour, but perhaps it's because I don't understand Rigid Body Worlds well enough.

Here's 2 unexpected behaviours in my opinion:

(1) Even when there is no Rigid Body World group set, the objects set to Rigid Body Physics have strange behavior. They do not follow their F-curves as in the example file I attached. Specifically, unless the Animated property is enabled, they just remain motionless. But if they're not part of Rigid Body World, then shouldn't they follow their F-curves?

(2) When you first set a rigid body object, a Rigid Body World is automatically created and it is automatically sets the Rigid Body World Group in the Scene context of Properties window. So the user never has to do this normally. Then if the user, hits Remove Rigid Body World (say by mistake), but then immediately hits Add Rigid Body World. This time, no group is given, so many users will not think that they need to manually set the group, since they may have never done so before. Perhaps a group should get automatically assigned like it does the first time Rigid Body World gets created.

@Garrett (Garrett):
I agree, I'm not a fan of the use of groups here either. But it was decided to use them here and it's hard to change it now.

Sergej Reich (sergof) closed this task as Invalid.Mar 31 2014, 4:17 PM