Knife tool doesn't maintain snap to center when holding ctrl button.
Closed, ResolvedPublic

Description

System Information
Windows 7 x64 Home Premium, ATI Mobility Radeon HD 5470

Blender Version
Broken: 2.70
Worked: 2.69

Short description of error
In 2.69 when holding the ctrl key if you click on two edges all the ones in between would snap to center. In 2.7 only edges that are explicitly selected will snap to center meaning that you have to click each edge rather than being able to select a range of edges.

Blender 2.69

Blender 2.70


Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Howard, you may know whether this is intended change or actual regression? Or maybe Campbell?

Bastien Montagne (mont29) triaged this task as Normal priority.Apr 6 2014, 8:05 PM

I can see both behaviors as being useful, but might as well make it do what it used to do. I will work on this when I get some time.

Behavior is still unchanged in 2.70a

Revision rBf2f3ef869237116cea90b8cd0bdaddc43c7f0af3 reverts to the 2.65 behavior.

I had thought that maybe it was better not to snap the intermediate points, since what if that's what you wanted? How would you do it? But I guess you can kind of line your cursor up with the snapped place on the final edge, and then let go of Control. Anyway, since it appears you find the old behavior more useful and it used to do that, I changed the behavior back to snap to the intermediate points too.

Howard Trickey (howardt) closed this task as Resolved.Apr 16 2014, 8:26 PM