Page MenuHome

vertex painting with a mouse doesnt work at all
Closed, ArchivedPublic

Description

System Information
manjaro linux, ati radeon 4650 (radeon driver)

Blender Version
Broken: (example: 2.70 19e627c , see splash screen)
Worked: (optional)

Short description of error
Blender doesnt draw the vertex paint at all when using a mouse.
shift+k (fill color) works, but the brush painting doesnt.
With the Draw Brush.

If you select specific faces in edit mode and toggle on face selection mask in vertex paint mode, shift+K doesnt work at all. I wish it could fill only the masked area.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Todor Imreorov (blurymind) created this task.
Todor Imreorov (blurymind) raised the priority of this task from to Needs Triage by Developer.

I would like to add that this worked just fine in 2.69.

It is broken in both trunk and blender 2.70's official release.

This affects the viewport and the rendering in BI as well. The vertex colors dont draw as expected.

However when opening the same file in 2.69, it looks like the changes to the vertex color data did happen. It's just that 2.7^ has trouble registering them.

Please attach a blend file and exact steps to redo the bug.

I tested on subdivided cube and vertex paint with face select works fine when toggling in/out of editmode,
with paint and filling (Shift+K)


@Todor Imreorov (blurymind) - you have been reporting a lot of bugs (which is great), but please try improve the quality of your reports. Just replying to reports which don't contain enough info (or attempting to guess what reporters mean) takes time away from development.

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

did you try painting on it with a brush?

@Todor Imreorov (blurymind) - yes. can you attach a file setup in a state which fails?

it does it on the default cube as well. I think this is an issue with radeon's open source driver under linux.
Its not even doing it consistently.

I will give it a spin under windows, where its ati's official driver.

Uh, did not even read this this morning… I can confirm this is an issue of free radeon drivers (only true when VBO is enabled). I suggest you to disable those VBOs (in UserPreferences, System tab), at least for me it fixes that kind of issues.

hi, thank you for confirming this. Disabling vbo fixes the issue!!

Maybe it should be noted in the release notes?

Recently manjaro linux enforced an upgrade and now it is impossible to use the legacy catalyst driver any more , because it is not compatible with the new xorg.
The situation is the same with most linux distros. They are dropping support for the catalyst driver.

Bastien Montagne (mont29) closed this task as Archived.Apr 16 2014, 8:50 PM
Bastien Montagne (mont29) claimed this task.

Oki… Closing, then, OGL driver issue, we can’t do much about it (and adding notes about all issues of that kind in our release notes would make them awfully ugly and big :/ ).