Page MenuHome

F-Curve Auto Snap problems
Closed, ResolvedPublic

Description

System Information
Windows 7 32 bit
AMD Radeon HD 7310M

Blender Version
Broken: Blender 2.70a, win 32 bit, f93bc76.

Short description of error

When moving keyframes with G, Auto Snap modes dont work as expected.

Exact steps for others to reproduce the error

  • I added some keyframes to Cube X location.
  • File:
  • In the Graph Editor, Auto Snap is set to Nearest Frame.
  • Select a keyframe then move it left or right. Works as expected, snapping to frame.
  • Via View Menu enable Show Seconds.
  • Select a keyframe then move it left or right. Snaps to +24, same as FPS. This maybe Bug. Nearest Frame "Snap to actual frames/seconds (nla-action time)". With the enum set to Nearest Frame, it should still snap to frames.
  • Via header set Auto Snap > Time Step.
  • Select a keyframe then move it left or right. No snapping. This maybe Bug. I would of thought this would snap to +24.
  • Via View Menu disable Show Seconds.
  • Select a keyframe then move it left or right. No snapping.

Event Timeline

koil (koilz) updated the task description. (Show Details)Apr 21 2014, 2:00 AM
koil (koilz) set Type to Bug.
koil (koilz) added a subscriber: koil (koilz).
koil (koilz) created this task.
koil (koilz) raised the priority of this task from to Needs Triage by Developer.

Thanks for the report. This is on my todo list as a bug that needs to be fixed.

Joshua Leung (aligorith) triaged this task as Confirmed, Medium priority.Apr 21 2014, 2:14 AM

Just a little update: I've fixed the bug locally, but in the process have ended up discovering 4-5 other related problems here. One unresolved one is T39880, which I'll look into again tomorrow after getting some sleep :)

Thanks for fixing this. Seems like a new set of tools.
Ill have to download a recent build sometime.