Page MenuHome

Transformed parents of Rigid Bodies cause problems with Bake To Keyframes
Closed, ResolvedPublic

Description

System Information
OS X 10.8.3
NVIDIA GeForce GTX 680MX 2048 MB

Blender Version
Broken: 2.70a Official Blender Foundation release

Short description of error
When a PARENT of Active Rigid bodies has been transformed, Bake Keyframes doesn't recognize these transforms in the children, though the real-time Cache and standard Bake methods do.

Exact steps for others to reproduce the error
In attached .blend file, play back the physics sim. Note the Suzannes fall in the box like they should.
Select the Suzannes and BAKE TO KEYFRAMES (ff 0-100). After Baking, the Suzannes fall in the wrong place.

WHAT I THINK IS GOING ON: The Suzannes are CHILDREN of the cube. The Cube has been moved from [0,0,0] to [5,5,0], and rotated from [0,0,0] to [0d,0d,90d]. This displacement seems to be magnified by the Bake to Keyframes. Scaling the parent creates even stranger results.

Applying the transformation / rotation / scale, or unparenting the Rigid Bodies removes this problem when Baking to Keyframes. However, for complicated sims, parenting is a useful technique for setting things up, and at any rate the Bake should match the Bake to Keyframes.

Event Timeline

ben u (benu) raised the priority of this task from to Needs Triage by Developer.
ben u (benu) updated the task description. (Show Details)
ben u (benu) added projects: BF Blender, Physics.
ben u (benu) set Type to Bug.
ben u (benu) added a subscriber: ben u (benu).

@Sergej Reich (sergof) I think this is something for you ... As I see it, the RBs are rotated because the rotation of the cube is not applied previously...but I wonder if that is intentionally. The results of "baking" and "bake to keyframes" should be always the same I would assume - even if you didn't apply the rotation on the parent, right?!
@ben u (benu) Apply the rotation on the cubical object - all will be good then.

Greetings, Thomas

Sergej Reich (sergof) edited this Maniphest Task.Apr 25 2014, 8:22 AM
Sergej Reich (sergof) closed this task as Resolved.Apr 25 2014, 8:22 AM

Closed by commit rB258e30f2c7d2.

Thank you, Thomas! Thank you, Sergej!

Sergej Reich (sergof) edited this Maniphest Task.May 12 2014, 4:49 PM