Page MenuHome

Graph editor, active keyframe panel, handle update coordinates.
Closed, DuplicatePublic

Description

System Information
Windows 7 32 bit.
AMD Radeon HD 7310M.

Blender Version
Broken: Blender 2.70a, win 32, f93bc76.

Short description of error
The keyframe handle coordinates update odd, when setting the handle coordinates in the graph editor, active keyframe panel.

Exact steps for others to reproduce the error

  • Here ive added some keyframes to cube X Location.
  • The handle type is Automatic I think, the default one.
  • First select one of the keyframes.
  • Via the Active Keyframe panel, slide the Left handle coordinates, X and Y.

When the X is updated, it updates the right Y, mostly.
When the Y is updated, it updates the right Y, mostly.

  • Via the Active Keyframe panel, slide the Right handle coordinates, X and Y.

When the X is updated, it scales the right handle.
When the Y is updated, it seems to increment the right handle scale, if the value is set lower or higher.

The sliders also update the handles differently, if different parts of the keyframe are selected Shift+RMB, left or right handle only for example.

Event Timeline

koil (koilz) updated the task description. (Show Details)Apr 26 2014, 8:03 PM
koil (koilz) set Type to Bug.
koil (koilz) added a subscriber: koil (koilz).
koil (koilz) created this task.
koil (koilz) raised the priority of this task from to Needs Triage by Developer.
Joshua Leung (aligorith) triaged this task as Confirmed, Medium priority.Apr 28 2014, 6:24 AM

Indeed, it seems that it's only when editing the Y coordinate of the right handle (when both handles are of type "aligned") that problems occur.

This is potentially related to T38594 so I'll see whether Brecht's patch for that resolves this issue too.

Joshua Leung (aligorith) closed this task as a duplicate.Apr 28 2014, 6:35 AM

✘ Merged into T38594.

Although I merged this task into the other one, upon further investigation, it turned out that they weren't exactly due to the same problem (i.e. this one still remained after solving the other; in fact, the other made this worse). Regardless, I ended up whipping up a hack to fix this particular bug (c504b8b)

So, closed and fixed this time.