Page MenuHome

Linking path problem
Closed, ArchivedPublic

Description

System Information
OS: windows7 64bit
GPU: nvidia quadro k4000

Blender Version
Broken: 2.70a offical release
Worked: 2.69 official release

Short description of error
some weired stuff happening with the linked path

Exact steps for others to reproduce the error

i don't know exactly in which situation this happens but sometimes the linking messes up the path and it assumes that the blend file is in c:\ instead of the correct path.
heres the error i get with 2.7+
all i do is link a object from one scene into a other and then try to reload the scene.

Info: Read library:  '\..\Tools\Synthes\KWire_Diamond\blend\KWire_Diamond.blend', '//..\..\..\..\..\..\..\..\Tools\Synthes\KWire_Diamond\blend\KWire_Diamond.ble
nd'
Warning: Unable to open '\..\Tools\Synthes\KWire_Diamond\blend\KWire_Diamond.blend': No such file or directory
Warning: Cannot find lib '\..\Tools\Synthes\KWire_Diamond\blend\KWire_Diamond.blend'
Info: Read library:  'C:\TraumaSim.blend', '//..\..\..\..\..\..\TraumaSim.blend'
Warning: Unable to open 'C:\TraumaSim.blend': No such file or directory
Warning: Cannot find lib 'C:\TraumaSim.blend'
Warning: LIB ERROR: Object: 'KWireGhost' unread lib block missing from '\..\Tools\Synthes\KWire_Diamond\blend\KWire_Diamond.blend'
Warning: LIB ERROR: Object: 'Tibia' unread lib block missing from 'C:\TraumaSim.blend'
Warning: LIB ERROR: object lost from scene: 'Scene'
Warning: LIB ERROR: object lost from scene: 'Scene'

if you need more information please let me know so i can allocate some time to for reproducing this problem.

Details

Type
Bug

Event Timeline

dan grauer (kromar) set Type to Bug.
dan grauer (kromar) created this task.
dan grauer (kromar) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

Ofcourse we do need more information, in particular exact steps reproducing the issue, or at least .blend files which worked in 2.69 and doesn't work in 2.70.

Bastien Montagne (mont29) closed this task as Archived.May 6 2014, 7:29 PM
Bastien Montagne (mont29) claimed this task.

No answer since one week…

finally got time to take the scenes apart so i can submit them here. you will find 2 blend files in the packed file with the same folder structure that i use.

so how to reproduce this issue:

  1. open the leg.blend
  2. you will find that the Wire object is already linked from the wire.blend scene.
  3. either use the addon library linking to jump to the wire.blend or open it manually
  4. in the wire.blend file link in the skin object from the leg.blend file
  5. either use the library linking addon again to jump back to the leg.blend or manually save the wire.blend
  6. if you used the library linking addon jump back to the wire.blend file again with it and notice that the skin is not linked anymore and you will find some similar output like i posted in the first post.
  7. if you manually saved the wire.blend file then either manually reload it or use the "revert"(which should be renamed to reload) option in the file menu to reload the wire.blend file and notice that the skin is not linked anymore and you will find some similar output like i posted in the first post.

dan grauer (kromar) reopened this task as Open.May 9 2014, 2:59 PM
Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.
Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.
Sergey Sharybin (sergey) closed this task as Archived.May 19 2014, 5:20 PM
Sergey Sharybin (sergey) claimed this task.

The path in Wire.blend is simply broken. it reads library "..\..\..\..\..\..\Leg.blend" which is totally outside from your project folder. It should be "..\..\..\..\Leg.blend". Saving files with broken links would lead to data loss for sure.

dan grauer (kromar) added a comment.EditedMay 19 2014, 5:50 PM

i dont know how blender refers to such a path, thats why im creating this report.
my savings are exactly in the same file structure as in the files i attached.
if you make such a claim, maybe you can explain to me how i would save a file with a so called "broken" path. because i dont know how to save a file with a path i can not define and doesnt even exist...

"//" means the path is measured relative to the current .blend file. "..\" means going to the parent directory. Relative path might become incorrect when you move files around in a file browser or so.
If you didn't change location of the .blend files and run into an issue with wrong paths, that'd be an issue and we'll need to know how to reproduce such situation from scratch.

im pretty sure i did not move any files around because im fully aware that this messes up the relative paths. i will have a look today if maybe a coworker did something which could cause such an issue but i was the only one working on these projects so its unlikely...
i replaced a drive recently but the drive letter and the location of the files is the same again so i dont see how this would break the relative paths.

Well, the thing is. Something breaks relative path for you and we can'r really guess what exactly. We need your collaboration here :)
If we know which step exactly breaks the relative path then we can totally fix the issue.

i understand and i will see if i can allocate some more time or give time to my intern to try and reproduce this somehow.

i did some further testing and the problem happens when i link an object in with a relative path. with absolute path it works fine but as soon as the path is relative i get these funky paths.

i also tested in a old version 2.60.0 and there it works without any problems. i will do some more testing to narrow down the search for the issue.
i also found a old report that sound very similar to my problem, i believe the fix that was done there did not really fix the issue.

old report about same issue:
https://developer.blender.org/T37240

It might be related, maybe not. Really difficult to tell for sure without having exact steps reoproducing the issue.

Also, just for the record, all open movies production files always uses relative path. And the fact that we didn't have issues with paths there means that we REALLY need exact steps which moves linked files from consistent state to a broken one.

we are working on it but its hard to tell what is reproducable on your machines when the issue can be reproduced every time on the file we provide but you tell us you can not reproduce it....

i wrote the exact steps with the attached file structure and i can reproduce it every time so i dont know why this would not happen on any other (windows) system.

It seems this issue rises as a result of having .blend files that link to assets in one another. That is, A.blend has an object, "1" that is linked from B.blend. And B.blend has an object, "2" that is linked from A.blend. It's kind of a circular linking scenario.

Assuming that is the culprit, a few follow-up questions (mostly related to the Edit Linked Library addon you're using):

  • Are you seeing the same behavior in all three of the following:
    • Direct linked objects/data
    • Linked groups that you make a dupligroup instance of
    • Linked groups with proxies
  • Do you have autosave enabled or are you saving manually when switching files?
  • Are you spawning a separate Blender instance or are you using the same instance?

The bug occurs in all three cases under the following circumstances:

Switching blend files with the "Edit linked library" addon.

  • Autosave enabled
  • Blend files have to be in different sub-folders

How to reproduce:
Blender version. 2.70a Hash: f93bc76

You can do it within the same blender instance. Happens with linked, dupligroup and proxies.

  1. Make two new blend files. One with with a Cube. One with a Cylinder. Each within its own subfolder.
  2. Link the Cube into the Cylinder.blend file. Save it. (Check the "Relative Path" to enabled when linking.)
  3. Link the Cylinder into the Cube.blend file. Save it. (Check the "Relative Path" to enabled when linking.)
  4. Open each file individually, check if anything linked is missing (NOTHING should be missing).
  5. Open the Cube.blend file. (NOTHING is missing).
  6. Use the "Edit linked library" addon to switch to the Cylinder.blend file. Be sure to have the "Autosave" checkbox enabled.
  7. You are now in the Cylinder.blend file. (NOTHING is missing).
  8. Use the "Edit llnked library" addon to switch back to the Cube.blend. Be sure to have the "Autosave" checkbox enabled.
  9. You are now back in the Cube.blend file. (NOTHING is missing).
  10. Use the "Edit linked library" addon to switch back to the Cylinder scene. Be sure to have the "Autosave" checkbox enabled.
  11. You are now back in the Cylinder.blend file (BUG: Cube is missing, still linked, but linked library datapath is wrong)

Same problem in 2.78a using "Edit Linked Libraries" addon
The problem to me occurs only into Windows OS, not in linux because of the different slash-backslash I think

If you have some issues please submit them as a new report with proper steps reproducing the error.

I saw now that this is closed... really sorry about that, I will open a new one