Page MenuHome

Hangs indefinitely sometimes during compositing render preview
Closed, ResolvedPublic

Description

System Information
Windows

Blender Version
Broken: 2.70a

Short description of error
When messing around with masks or doing anything with lots of subsequent operations that cause Blender to automaticaly re-render, sometimes Blender can't keep up and stalls out. I've waited 20 minutes sometimes and Blender just sits there frozen.

Exact steps for others to reproduce the error

  1. Set up compositing nodes involving, for example, an HD video clip, a mask, and a viewer node.
  2. Go to the UV/image editor, select the viewer node as input and switch to Mask mode,.
  3. Drag your mask points around, forcing Blender to re-render as you are dragging. Keep moving that mouse around and eventually Blender will freeze.

Details

Type
Bug

Event Timeline

Fluffy Rabbit (fluffrabbit) created this task.
Fluffy Rabbit (fluffrabbit) raised the priority of this task from to Needs Triage by Developer.
Lukas Toenne (lukastoenne) triaged this task as Needs Information from User priority.

I can't reproduce this (arch linux 64bit, GTX 660). Please attach a test file so we can be sure to test the exact same setup. It might be a windows-only issue, but can't say at this point.

I can't seem to reproduce it this morning either. Not one crash. It's really frustrating because I don't know what other variables are involved. I'm attaching a blend file that is supposed to represent the steps I described, but it's solid as a rock. I've tried several different blend files and no crashes. :( I also can't seem to attach a file in IE9, so I've uploaded it to another site.
http://www37.zippyshare.com/v/15158598/file.html

Bastien Montagne (mont29) closed this task as Resolved.May 15 2014, 9:26 PM
Bastien Montagne (mont29) claimed this task.

Adding the file here just for the records.

Else, assuming this is fixed, thanks for the report!