Page MenuHome

Path Bevel Pinching
Closed, ArchivedPublic

Description

System Information
Confirmed on OS X 10.6.8 MacBook Air 11-inch
Other users reported the same results but I do not know their system specs.

Blender Version
Broken: 2.70a f93bc76
Worked: May have worked in 2.62.1 - based on the training DVD "Interior Architectural Visualization" Chapter 4: "Modeling the Trim"
In this tutorial the author is able to Toggle Cyclic while the curve is 3D without any pinching at the corners.
The results that myself and other users are now getting are different from what is demonstrated in the training DVD.

Short description of error
When using a Bevel Object along a path Curve, pinching occurs at corners.
I consulted with some other users and it was suggested this could be a bug.
Oddly, switching the path Curve from 3D to 2D fixes the problem, but in doing so one obviously becomes limited in what kinds of geometry can be made.

Note that if the path Curve is Cyclic (closed loop) the pinching occurs evenly at each angle of the path and is less obvious, but one can still see a difference in thickness if setting the curve from 3D to 2D.

Exact steps for others to reproduce the error

  1. Load the sample .blend

-OR-
Add Curve > Circle, then Add Curve > Bezier, set its handles to Vector, in curve properties set the BezierCircle as the Bevel Object.

  1. Change the path Curve from 2D to 3D and the problem goes away. Thickness becomes uniform, but 2D is restrictive.

Details

Type
Bug

Event Timeline

Seth L. (quantumanomaly) set Type to Bug.
Seth L. (quantumanomaly) created this task.
Seth L. (quantumanomaly) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Normal priority.

Will have a closer look later a bit.

Sergey Sharybin (sergey) closed this task as Archived.May 15 2014, 3:54 PM

It's just a difference in how offset is calculated in 2D and 3D spaces. You can make 3D curves working fine by changing points's radius or just stick to 2D curves. It's possible to support this particular case for 3D curves as well, but this would break some other files.

So thanks for the report, but would consider this is a possible improvement for later,

Sorry to stir this up Sergey (and nice to meet you BTW !), but I'd like to understand the reason for dismissing this rather faulty behaviour and leaving it be.

I mean, the result it gives is apparently faulty, and not quite what is expected. How can that be satisfactory ?
Breaking some other files shouldn't be a concern when the implementation of the feature is corrected, in my view. After all, if one prefers a faulty behaviour, one can always work with an older version of Blender.

I may well be wrong, but I don't think it is doing Blender a favour to leave this sort of glitches…

I don't want to be rude by questioning your decision to close that bug report, I'd rather like to know the rationale behind it. It seemed to me to be a perfectly valid bug report, in the sense that users can't get the tool to work in a consistent way without cheating. Or maybe I don't understand the tool correctly !?

Bests,
Gwen

I hit this exact same thing. If this is desirable behavior, how can we achieve a more natural 90 degree turn when using the bevel shape on a path?

Just adding my opinion.

Sergey is right that changing this might break behaviour with some files (that have come before).

On the other hand, I agree that this current behaviour is not what the average user (like me) expects and I would vote to change (improve) this in the future.

However, instead of just trying to change this willy-nilly, it might be best to get opinions from a significant number of users to get a group consensus on what behaviour(s) and control possibilities they would like from this function.

Once there is a clear decision I would then (re)write the code to get the best possible functionality.

So, yeah, (as Sergey says) "a possible improvement for later."

Last comment.. I promise.. ;) How can this be converted into a feature request that simply gives the user the option for something like "Path Folding" or "Corner Compensation" behavior? I'd hate to lose track of this one. It seems like if this were implemented as a simple selection (with the default being "no matching" or "no compensation"), that it would solve the underlying issue as well as give the user the option to have it either way. For architecture models, it seems the current behavior is definitely not very desirable. Plus, the code already seems to work both ways.
Thanks again!