Page MenuHome

Bugs with Edge Flags and Booleans
Closed, ResolvedPublic

Description

System Information
Win7 64, GTX 560 ti

Blender Version
30361a7

Short description of error

  1. Bevel Weigth not work if the object have a Boolean Modifier
  1. When you apply a Boolean Modifier Edge flags like Sharpen and Seams (Mark Sharpen, Mark Seams) only are applyied to the final mesh if the Root (the mesh with the modifier ) already have some edge with that flag. if it never has a edge with that flag the final mesh don't apply the flags from the "Mask" object ( the other object of the boolean operation )

Exact steps for others to reproduce the error
1.1) Make a Cube, add a boolean modifier in the stack. point to a object, add a bevel configured with Limit for Weight... Limit does not works. Do the same with Crease and a Subdivision modifier instead Bevel and it works...

  1. Make Two cubes, apply a Boolean modifier in Cube1 and set to Cube2. In Cube2 mark all edges as Sharpen or Crease Apply it. The Sharpen and Crease config will not be in the Result

OBS : Crease Seams to work but i don't have tested to much

Example:

Event Timeline

Vitor Balbio (vitorbalbio) created this task.
Vitor Balbio (vitorbalbio) raised the priority of this task from to Needs Triage by Developer.

It's not a bug in boolean, in fact i'm not sure whether it's bug at all.

The thing is, for until you mark any seam or sharp on mesh it does have "Show Seam|Sharp" disabled. So what's happening is: boolean modifier copies all the data nicely but just edit mode doesn't display anything. If you go to Mesh Display panel and enable display seam|sharp you'll see an expected result.

It could be improved perhaps, but modifier stack doesn't store this flags, so it's not quite possible to enable display seams|sharp based on both operands' settings. So for me it looks like the only thing you might do is to enable the display flags manually..

@Campbell Barton (campbellbarton), other ideas?

Sergey Sharybin (sergey) closed this task as Archived.May 16 2014, 1:39 PM

So we've talked to Campbell in IRC. And the confusion is coming from Set Seam/Sharp is setting corresponding Display flag, so you don't worry about this. But boolean modifier can't have affect on this setting, even when you apply it. And even if it could, it's still probably not what you want really. Show Seams might have been disabled on purpose and enabling it would confuse..

So we think it's not that case when something is to be really changed in Blender. At least not for supporting this particular case. Improvements are always possible, but here it'll involve some bigger discussion about workflow and trying to find a compromise when blender actually does what you expect..

Thanks for the report, but it's not a bug, just something which might communicate a bit better perhaps.

I see it know, i complete forgot about the Show Seams and Show Sharpen flags "per edge". I think you're right on it.

And about the Bevel Weight stuff that i posted in topic (1) "Bevel Weight not works if the object have a Boolean Modifier" ?

That's weird indeed. Can't tell anything yet, would need a closer look/

Sergey Sharybin (sergey) triaged this task as Normal priority.May 19 2014, 10:13 AM

It's an issue in DM_to_bmesh which doesn't allocate CD_BWEIGHT layer. Boolean modifier sets edge's bweight just nicely ;)

Just a note: the boolean modifier doesn't copy the Freestyle Edge attribute like Sharp or Seam. I know it stored differently as a separate data array. Maybe the same problem for the bevel weight?

There's a patch to fix it already? Or it's more complicated?