Page MenuHome

Multi button editing impossible to tell with color selectors
Closed, ResolvedPublic

Description

System Information
Archlinux
GTX 460

Blender Version
Broken: testbuild2 (517094a)

Short description of error
Sliders in color selectors don't change when drag selected with multi button editing.

This actually goes for any of those kind of sliders (with the sort of progress bar look), but color selectors are the only place I could think of right away where multi button editing is useful, and those kinds of sliders are used.

Exact steps for others to reproduce the error

  1. Open blender
  2. Click on a color swatch
  3. Position the cursor over the red channel and depress LMB
  4. Move the cursor downwards. Nothing will seem to happen (though if you move the cursor not quite straight down, you might notice https://developer.blender.org/T40533)
  5. Release LMB. Depending on how far you moved the mouse, some or all of the channels will be "opened" for editing.

Event Timeline

Ellwood Zwovic (gandalf3) raised the priority of this task from to 90.
Ellwood Zwovic (gandalf3) updated the task description. (Show Details)
Ellwood Zwovic (gandalf3) edited a custom field.

It's actually working for me (the same 517094a on Ubuntu 64bit) but if I'm using this multi channel feature on the "Dimensions" block for the default cube, only the X and Z values are changing.

@Fazekas Laszlo (totoro) "Dimension" issue is known (and reported somewhere), it’s complex to solve (due to how dimension works internally).

@Ellwood Zwovic (gandalf3): can’t reproduce this with latest master either, color sliders behave like any other group (i.e. OK).

The values change, but the appearance of the slider does not change visually (indicating that it is now selected) while dragging the cursor vertically.

This makes it hard to tell how many sliders are being selected while dragging vertically, as the mouse cursor is hidden by continuous grab.

@Ellwood Zwovic (gandalf3): Are you using the default theme? What are the colors at your User Preferences - Themes tab - User Interface - Value slider section? The color for the selected slider is the "Inner selected" here.

@Fazekas Laszlo (totoro) I'm using the default theme. The problem is when all the values are at 1, so that the inner selected color is not visible.

I would expect the item gradient to invert and the text turn white, like the first-clicked button, however it does not.

@Ellwood Zwovic (gandalf3): You're right, I understand now. :D It's because the text colors are not changing. I confirm this too.

Fazekas Laszlo (totoro) lowered the priority of this task from 90 to 50.Jun 9 2014, 5:58 AM

It's not easy to find a nice text color here. This is my attempt. @Bastien Montagne (mont29), could you check it please?O_O

Patch makes sense to me, but would rather let Campbell decide here.

Campbell Barton (campbellbarton) changed the task status from Unknown Status to Resolved.Jun 9 2014, 1:07 PM

Closed by commit rB5b367c9aaf4f.