Page MenuHome

Extrude can invert some normals
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: Blender RC1
Worked: (optional)

Exact steps for others to reproduce the error

  • File -> Load Factory Setting
  • Delete default cube
  • Add a Mesh circle
  • Go on top view (numpad 7) and ortho (numpad 5)
  • Go to Edit Mode
  • delete the lower half of the circle vertices (only the ones in the negative Y axis , do not delete the ones that are on the X axis)
  • select the 2 vertices at the extremities of the half circle
  • Press E then Y and move them down on the negative Y Axis for 1 unit or 2
  • Select All
  • Press E then S (or ALT S if you want) and notice the different faces shading, meaning they do not have all the same expected normals direction.

Event Timeline

Sanc Tuary (sanctuary) set Type to Bug.
Sanc Tuary (sanctuary) created this task.
Sanc Tuary (sanctuary) raised the priority of this task from to Needs Triage by Developer.

I meant Blender RC2 for the problem described, not RC1 sorry

I think I reported something similar a while ago and they said it's not a bug. Through I am pretty sure if they wanted they could find a fix based on the camera angle view.

Not a bug strictly speaking, but this case can be made to work.

Resolved rB728041019e8ee30a939a521c251d60e1f996a313

Sanc Tuary (sanctuary) reopened this task as Open.Jul 20 2014, 3:03 AM

Sorry to re-open, but after having tried a build from buildbot :
blender-2.71-e0d8e62-win32

While It seems that while it looks fixed for the example i showed at in the report, since then in Blender 2.71 "stable" and in several buildbots version i ran into many normals problems from just simple extrusion,s so it looks like the problem isn't solved .

I found since then an even simpler example to get wrong normals, those following steps will reproduce it even in latest builds :

  • Load a recent build of Blender
  • File -> Load Factory Settings
  • Press Numpad5 to go in Ortho view
  • TAB to go to Edit Mode
  • X -> Vertices to delete the default cube
  • Add -> Plane
  • Press E then type -1 , it will extrude down in the Z axis
  • the result is the mesh obtained has inverted normals instead of the expected correct ones

That is for just a plane, for nearly every model i've been working , this situation happens a lot, leading the user to have to select all and CTRL+N regularly to recover the correct normals.

Campbell Barton (campbellbarton) closed this task as Resolved.EditedJul 20 2014, 6:01 AM

If the reported problem is fixed but you found some different problem. Better open a new report. (Closing)

Note, when you extrude, the flipping of faces depends on the direction you move the mouse, not sure we should attempt to guess this ahead-of-time.