Page MenuHome

Remove Level of Details command = crash
Closed, ResolvedPublic

Description

System Information
Windows 7, 64 bit

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error
Blender crashes on random command

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Open Blender, have no object selected or nothing in 3D view, then tap spacebar and run "Remove Level of Details". Boom, Blender crashes.

Event Timeline

Jimmy Gunawan (enzyme69) raised the priority of this task from to Needs Triage by Developer.
Jimmy Gunawan (enzyme69) updated the task description. (Show Details)
Jimmy Gunawan (enzyme69) set Type to Bug.
Thomas Dinges (dingto) closed this task as Resolved.Jun 26 2014, 11:53 PM

Closed by commit rB92ecbd2998c6.

Same happens with the Add LoD operator @Mitchell Stokes (moguri)

Maybe we should use different operator polls which check for a valid object as well. Can you take care of that?

That would fix the crash, but would not check for Objectmode anymore, not sure we need that though?

I don't think it is necessary. I experimented with adding and removing LoDs while in edit mode, and it did not appear to be a problem. To be honest, that poll method was most likely used because it was probably what the operator I was using as a reference used.

Okay, in this case, please commit your patch. :)

Daniel Stokes (kupoman) edited this Maniphest Task.Jul 2 2014, 3:13 PM