Page MenuHome

Scene rendering in 2.70a is crashing 2.71, latest build (Cuda centric)
Closed, ResolvedPublic

Description

System Information
Windows 7 SP1
2 X Asus ROG MARS760-4GD5 (http://www.asus.com/ROG_ROG/ROG_MARS7604GD5/)
Nvidia Driver Version: 337.88

Blender Version
Broken: 2.71
Worked: 2.70a

Short description of error
I have a scene that I produced in 2.70a which is persistently crashing in 2.71. I tried again after deleting my prefs, to no avail. The scene rendered just fine in Cycles 2.70a in Cuda Mode with all the GPU's active, in 2.71 it crashes. It renders in CPU mode though...

Exact steps for others to reproduce the error
1- Download the project Dir from:
https://dl.dropboxusercontent.com/u/28170294/THE_ALTUG_LEASURE_ESTATE.rar
2- Open the scene AL_ESTATE_WIP_NEW_15.blend in the WIP folder.
3- Change the render device to CUDA and render a frame. There's no animation...

Details

Type
Bug

Event Timeline

Ajlan Altug (jacobo) raised the priority of this task from to Needs Triage by Developer.
Ajlan Altug (jacobo) updated the task description. (Show Details)
Ajlan Altug (jacobo) set Type to Bug.

Will have a look. CCing @Thomas Dinges (dingto) just in case he'll be faster than me :)

He's got multiple GPU's I take it :) Kewl :) Thanx Sergey :)

Hi, I can render the file with 2.71 and 2.70a on my EVGA GTX 760 4GB.
2.71 has slight higher VRAM usage 2133 MB : 2032 MB.

Opensuse 13.1/64
Intel i5 3770K
GTX 760 4 GB (Display)
GTX 560Ti 1.28 GB 448 Cores
Driver 331.67

Cheers, mib

Higher VRAM usage ise due to new CUDA toolkit. This is known thing. Currently i only had access to a card with 1gig and it nicely prints Out of memory and doesn't crash.

Are there any messages printed to the console?

Upon reading Sergey's last message, I downloaded the latest build, but to keep things simple this time, I downloaded the self-contained zip version. And, weirdness to the max... This standalone copy renders in CUDA mode... I uninstalled the exe version that crashed last night and reinstalled 2.70a back again. I'm going to take the plunge and reinstall 2.71 exe version and report what it says in the console right away...

Ok... I think I got to the bottom of things. My oversight played a big part it turns out. Since I have lotsa addons in my addon folder, I took the liberty of backing up the entire addons folder along with my config folder. I surely hadn't realized that Blender is modular by nature and that cycles is also an addon, I foolishly seem to have replaced everything in the addons folder with the old 2.70a version... Arrghh!!! Sorry to have taken your time guys, but as always, thanx a million for being so considerate.

Lotsa cheers :)

AJ

Sergey Sharybin (sergey) closed this task as Resolved.Jun 27 2014, 10:33 PM

Hah, nice to hear it's all solved for you now!

Yes Sergey, me very happy now :) Allow me to thank you for another wonderful release. Will bug you guys again if anything comes up, but I'll try and be more thorough from now on before reporting :)

Cheers;

AJ