Page MenuHome

Bezier Hook to New Object does not work properly
Closed, ResolvedPublic

Description

System Information
ArchLinux 3.15.1-1-ARCH
GC: Nvidia GeForce 530 GT

Blender Version
Broken: 2.71 (Hash 9337574)
Worked: 2.70a (Hash f93bc76)

Bezier Hook to New Object does not work properly

Exact steps for others to reproduce the error

  1. Add a Bezier Curve
  2. Go to the Edit Mode
  3. Press V and select (Set Handle Type) to Vector
  4. Select left-one Handle point
  5. Extrude it by Z coord. (ex: E -> Z -> 2 -> Enter)
  6. Select the corner point of bezier curve
  7. Press Ctrl+H (Hooks) and choose "Hook to new object"

Now leave the Edit mode (back to Object Mode) and try to move newrly created Null object. You may see, that in 2.71 Null object doest not move the corner of the curve.

Not Work:

Work:

Event Timeline

Jack J (JackyJuice) set Type to Bug.
Jack J (JackyJuice) created this task.
Jack J (JackyJuice) raised the priority of this task from to Needs Triage by Developer.

2.71 version bug

Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.

The steps aren't that clear, not sure what you mean Extrude it by Z coord,
The other steps make sense but I can't redo the bug.

Could you include a blend file with the selection set, immediately before you add the hook?

Note that hooks on vector handles aren't likely to be so useful, but don't think we should prevent it, because you may add a hook, then change handle types its hard to completely avoid.
Nevertheless, if this is a bug, we should fix of course.

Hi campbellbarton, thx for your reply.

Here is the video that represents the bug:

And .blend file with the selection right before Ctrl+H:

And this is the video from ver 2.70a without the bug:

Checked with a recent build rB2e840e56cfce44c93576085170d46373934cbebd - and cant redo the bug. tested with bug.blend from post, https://developer.blender.org/T40877#9

Also checked with 2.71 release and it works too (adds hook where I'd expect, unlike the in bug.avi)

Could you check with an official 2.71 release build?

Im using an official build of blender.
But ok, i've downloaded new archive and tried with it. No changes, its working as before(not hooking to the right object).

But you can see the video above - its not my fantasy :)
So, may be its a bug with my other installed software? What information do you need to proove the bug?

I've got:
ArchLinux 3.15.1-1-ARCH
GC: Nvidia GeForce 530 GT
Python 3.4.1
gcc version 4.9.0 20140604 (prerelease) (GCC)
glibc 2.19-5
libglade 2.6.4-5
mesa 10.2.2-1
nvidia-libgl 337.25-2

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.

Campbell Barton (campbellbarton) raised the priority of this task from Needs Information from User to Normal.Jul 2 2014, 4:22 AM

iMac OSX 10.9.3
ATI Radeon HD 4850 512 MB
Blender 2.71 #9337574
(Works in 2.70 #19e627c)

Can confirm. Some observations:

  • in edit mode, in the hook modifier pressing "Select" highlights the final control point in the bezier, not the one originally chosen to have the hook
  • if there are only 2 control points it works OK
  • in a chain of 4 control points, if both of the two middle points (points 2 & 3 in the curve) are type vector, it works if the third is chosen but not the second
  • if a second hook is added to the failing point it works

Then I got bored ;)

Can confirm on 2.71 release linux x64

I also noticed that the hook empty is created a little off - not at the same position as the selected curve point.

Campbell Barton (campbellbarton) raised the priority of this task from Normal to Confirmed, Medium.Jul 2 2014, 11:08 AM

Thanks for testing @Gottfried Hofmann (gottfried), moving back to bf-blender,
but strange I cant redo this on same build 2.71 release linux x64

Here is a short video where I reproduce the bug:

https://www.dropbox.com/s/0rn36elqkpx6aag/T40877.mp4

(download it, the web-player skips the last few and most important seconds)

The hook is created at center of triangle selection (control points + its handles).

I can reproduce it, too. Simply pressing Assign button of modifier solves the problem.

I think being able to add a hook to Curve handles is an interesting feature.
In this case, for vector handles, it is irrelevant.
But think about animating a 2D Bezier Shape who looks like changing a 6 branches Star into a 6 petals Flower or dozen of waves with a stage set look, simply by transforming an empty.

Of course, something like that can be done by curve shapes. But it is more efficient to transform (move, scale, rotate) an empty than to create several shapes for that.

@Gottfried Hofmann (gottfried), thanks for the video - I tried the *exact* same steps and it still works fine for me.

Assigning to Sergey to check

Sergey Sharybin (sergey) closed this task as Resolved.Jul 7 2014, 9:44 AM

Closed by commit rBf4cf84507b46.