Page MenuHome

Drawing glitch with second window on file open
Closed, ArchivedPublic

Description

System Information
Windows 7, 64 bit, Quadro FX 4000

Blender Version
Broken: 2.71
Worked: 2.7 and previous

Short description of error
Not so much an issue however, it does annoying to see render glitch.

Exact steps for others to reproduce the error
I have separate window for Render View, so when I click Render, window will pop up.

I work in Cycles last night and with GPU enabled. Saved the file, reopen the blend with Render View active, the issue starts to appear here. Occassionally there is a glitchy windows just like scrambled pixels on top of Render View.

Hopefully it's not my graphic card dying.

Thanks.

Details

Type
OpenGL Error

Event Timeline

Jimmy Gunawan (enzyme69) raised the priority of this task from to Needs Triage by Developer.
Jimmy Gunawan (enzyme69) updated the task description. (Show Details)
Jimmy Gunawan (enzyme69) set Type to Bug.
Thomas Dinges (dingto) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jun 30 2014, 12:26 AM

Sounds just like a GPU/Driver glitch, maybe attach a screenshot? We can not guess what you see on your screen.

A couple of screenshots.

I think it's really related to the Render View Window.

I can send the Blend. I am going to delete the Scan Data, but leave the Blend setup as is.

Confirmed, when I open the blend, I get the second window with drawing artefacts. Closing it, then pressing F12 works fine though. So more a Blender/WM bug, rather than Cycles.

Thomas Dinges (dingto) renamed this task from Render View Draw Glitch Cycles Related to Drawing glitch with second window on file open.Jun 30 2014, 11:41 AM
Thomas Dinges (dingto) raised the priority of this task from Needs Information from User to Confirmed, Medium.

We have had bugreports before with blend files that had corrupted layouts.

In that case we need to know how the layout breaks in the first place (need steps to make a window with a broken layout)

@Campbell Barton (campbellbarton)
That is what I have been trying to explain in the first report. Let me explain it again in details:

  1. Property panel, Render tab, Display: New Window => When I hit F12, new window pops up and rendering on that window there.
  2. Do not close that window that displays rendered image. Save the Blend.
  3. Now, re-open the blend, and you will see the corrupted layout on that window.
  4. This bug appears in Blender 2.71.

Can't reproduce on linux (arch 64bit, gnome3, GTX 760)

Can't reproduce on linux (arch 64bit, GTS 450])

Checked this using vogl and bugle (OpenGL debugging tools), and they didn't complain about any invalid OpenGL use.

Moving this to OpenGL errors.
This is likely a graphics card driver bug.

Campbell Barton (campbellbarton) changed Type from Bug to OpenGL Error.Sep 12 2014, 3:54 AM

It happens here on Windows 8.1 64 bit on Nvidia GTX 650 4gb Nvidia driver 347.52

Aaron Carlisle (Blendify) lowered the priority of this task from Confirmed, Medium to Normal.Sep 10 2015, 9:01 PM
Aaron Carlisle (Blendify) closed this task as Archived.Apr 14 2017, 9:12 PM
Aaron Carlisle (Blendify) claimed this task.

Since your card only supports opengl 2.1 I am going to archive this with 2.8 bumping the requirement to 3.3.