Page MenuHome

Rendering: Alpha Channel is Broken.
Closed, ResolvedPublic

Description

System Information
Linux 64bit, nVidia gtx 256

Blender Version
2.71 2e840e5 (dayly build)

Short description of error
Alpha channel is broken! It should be fully White!

Image: http://i.imgur.com/HcNHHfQ.png
File: https://dl.dropboxusercontent.com/u/26887202/blender/test_alpha_Broken_01.blend

Alpha is broken in Cycles and in Internal renderers.

Exact steps for others to reproduce the error
Render.

PS: Please check if internal re

Event Timeline

paul geraskin (mifth) set Type to Bug.
paul geraskin (mifth) created this task.
paul geraskin (mifth) raised the priority of this task from to Needs Triage by Developer.

Oh, I got the same problem!! I'm new to Blender and I realized lately that when I save PNG as RGBA it does not preserve Alpha channel properly. Glad I'm not alone in this :)

Blender 2.71 ubuntu14.04 64bits

I confirm that there is a problem.

Render image in this .blend.

Composite node have a problem. When something is plugged in alpha channel, it modifies combined result.
When alpha socket from renderlayer is plugged into alpha socket of Composite node: it modifies alpha result instead of displaying same result than with no plugged.

Sorry , I forgot the hash : 61e5f81. There is no problem in official 2.71.

I've tested the wrongAlphaComposite.blend in latest master and crash, here's the debug log http://www.pasteall.org/52560

along with crash.txt tested in ubuntu 14.04 64bit.

Sergey Sharybin (sergey) closed this task as Resolved.Jul 1 2014, 6:26 PM

Closed by commit rBecc2e298e879.