Page MenuHome

Make Local button on the scene selection drop-down does not work
Closed, ArchivedPublic

Description

System Information
Linux bubastis 3.10.25-gentoo #10 SMP Thu Jan 30 22:17:35 UTC 2014 x86_64 Intel(R) Core(TM) i7-4800MQ CPU @ 2.70GHz GenuineIntel GNU/Linux
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1) (prog-if 00 [VGA controller])

Blender Version
Broken: git 0ea73023496d6af81b750a95395c3190f1c95039
Broken: 2.71 RC2

Short description of error

The "make local" button on the scene selection drop-down at the top of the UI does not actually convert the linked scene to a local scene.

Exact steps for others to reproduce the error

Use the File / Link menu option to link a Scene from an external file.
Use the scene drop-down to select that scene.
Click the "make local" button.
Become disappointed.

workaround
Create a new scene that links all the objects from the linked scene using the + / Link Objects menu option. After that is done you can unlink the linked scene.

Details

Type
Bug

Event Timeline

Robert Forsman (mutantbob) created this task.
Robert Forsman (mutantbob) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) claimed this task.
Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.

Will have a look later.

Sergey Sharybin (sergey) closed this task as Archived.Aug 12 2014, 7:49 PM

Yeah, there are quite a few of unsupported datablocks in there. That's annoying, but technically it's not a bug, just a thing to be improved.

Thanks for the report, we'll get into this one once the number of actual bugs is lower.