Page MenuHome

blender -b untitled.blend just quits on windows with v2.7
Closed, DuplicatePublic

Description

Win 7
Radeon 7400M

2.71

Summary:
blender -b just quits on windows with v2.7

steps to reproduce:
launch blender, save default scene as untitled.blend
The try to render in non-interactive mode. e.g.:

C:\Program Files\Blender Foundation\Blender>blender -b C:\Users\Martin\Documents\untitled.blend

And nothing happens (blender quits). use default scene which blender opens with. It renders interactively. If I repeat the above command without the "-b", blender finds and opens the file. Hitting the render button (interactively) does render an image. I have tried this with some of the benchmark files on BlenderArtists.org. Same results.

I have tried all sorts of arguments as listed on
http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Command_Line
...can't get it working

Best regards
Martin

Details

Type
Bug

Event Timeline

Martin Crawford (compositor1) updated the task description. (Show Details)
Martin Crawford (compositor1) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as a duplicate.Jul 2 2014, 8:35 PM

✘ Merged into T40907.

Uh, maybe was a bit quick on this one… I try to launch from the cmd box of windows, not from a windows console, right?

If it’s from a windows console, then I merged by mistake.

Else, it should work from console (M$ managed to break embeded py when ran without any std stream available, in there latest compilers…).

I was attempting to run blender -b from a cmd.exe window

Then please try to do it from a real commandline (console) window, here it should work at least.

How do I launch a real commandline (console) window?
Please advise

This is most likely not a bug but a user error, the windows commandline is cmd.exe and T40907 is not affecting it.

The expected output for:

C:\Program Files\Blender Foundation\Blender>blender -b C:\Users\Martin\Documents\untitled.blend

would be something like:

Read new prefs: C:\Users\Martin\AppData\Roaming\Blender Foundation\Blender\2.71\config\userpref.blend
found bundled python: C:\Program Files\Blender Foundation\Blender\2.71\python
read blend C:\Users\Martin\Documents\untitled.blend

Blender quit

There will not be any images rendered, in order to do that you need to specify an output, format and frame, as outlined here: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Command_Line#Render_a_picture

Example:

C:\Program Files\Blender Foundation\Blender>blender -b C:\Users\Martin\Documents\untitled.blend -o C:\Users\Martin\Documents\render -F JPEG -x 1 -f 1

which should result in frame 1 being rendered to:

C:\Users\Martin\Documents\render0001.jpg