Page MenuHome

Cycles crash on CPU rendering , CUDA works
Closed, ResolvedPublic

Description

System Information
Windows 8.1 Pro 64.bit
Core i5 8gb Ram Gygabite Geforce 650 GTX 4 GB

Blender Version
Broken: Blender 2.71 5aec61f (64bit) (buildbot sat 5) Happens in 2.71 rc2 (64bit) too

Instant crash on CPU Cycles render when opening a demo blender file from the official demo loop.
Exact steps for others to reproduce the error

Hit render and get some coffee and enjoy the crash of the titans =))

.blend file that gives this is 05_helicopter.blend in the http://download.blender.org/demo/ demoloop ( Siggraph 2013 ?!:D if it is still that demo... )

Details

Type
Bug

Event Timeline

Grigore Florin (numarul7) raised the priority of this task from to Needs Triage by Developer.
Grigore Florin (numarul7) updated the task description. (Show Details)
Grigore Florin (numarul7) set Type to Bug.

can't confirm

2.71 & master works fine

OS: ubuntu 14.04

No crash on Win 7 x64, 2ec0077 with CPU.

Thomas Dinges (dingto) lowered the priority of this task from Needs Triage by Developer to Normal.Jul 6 2014, 2:45 AM

Someone with Win 8.1 64 bit ... can check ?!

Here what I get instantly http://imgur.com/UXNMmUb

Happens on 32bit build 5aec61f and it is happening to build blender-2.71-81c3fc9-win64-vc9 , GPU CUDA render works perfectly , CPU crash.

Found the problem ... in this particular blend the render threads are set to fixed 64 yet I wonder why it crash ?
Does not crash if I save that particular blend with auto-detect (4 threads) instead of default 64

Yes, the 64 threads are odd, but it still rendered fine with that here. Maybe someone on Windows 8 can reproduce the crash.

It could be some race condition going on around, which is unleashed when using 64 threads -- this makes timing different and so.. In any case we'll need someone to reproduce the issue in order to be able to fix it..

Will check on win7 a bit later, maybe i'll be lucky :)

i can confirm this on Win8.1 x64

when i click render right after i opened the file blender crashes after about 2 seconds

when i open the file, change the threads to auto (8 threads) it renders fine. if i change it back to 64 fixed it also renders fine. now i reopen the file, so it's fixed 64 again from the beginning -> again crashes

Blender 2.71
i7-3740QM @ 2.70GHz
GeForce GTX 660m 2gb
16GB RAM

Martijn, maybe you could try to confirm this one? Thanks.

If two people can reproduce it, it’s no more unconfirmed really… Might be easier to reproduce with even highest number of threads maybe?

@Bastien Montagne (mont29), developers still can not reproduce tho, and if we can't there's no huge chance of the issue being nailed down :(

Few questions to those who can reproduce the crash:

  • Anyone builds blender himself? (so maybe one could get a backtrace)
  • Does the crash happens when using Fullsreen render or locked interface (the lock icon next to Display in render settings)?
  • Does the crash happen when rendering from the command line?

sergey, to answer your questions:

  • no, i'm using the official build from blender.org 2.72a at the moment
  • it seems to be independent from that. no matter what i select in that dropdown or whether locked interface is active, it always shows the same behaviour i described in my last comment.
  • i tried rendering from command line: "C:\Program Files\Blender Foundation\Blender>blender -b D:\05_helicopter.blend -o D:\testrender_helicopter\ -F JPEG -x 1 -f 1". it successfully rendered and saved the file but there was an error message "Not freed memory blocks 2" when the render was finished. i don't know if this has anything to do with it but i've attached a screenshot of the output anyway.

You can add --debug-memory command line argument to blender before all of the rest ones to see which blocks are no freed. This could give some hints.

here's the output after adding --debug-memory

Do you mind testing latest builds from builder.blender.org? I did some threading-related fixes there today.

If it'll still crash, please try disabling "Save Buffers" in the preferences and see if it makes any difference.

ok, i did some more testing today with the versions from builder.blender.org the problem persists with blender-2.72-af92f3d-win64 and win64_cmake_vc2013

i couldn't find a save buffers in the preferences? if you meant the checkbox in the performance section of the rendersettings: that didn't make a difference

funny enough, the gooseberry branch seems to lock up blender too (no hover states for buttons for example) but as long as i don't click anywhere it seems to render in the background and then after it finished starts responding again. showing me the finished rendering. when not changing any settings and just hitting F12 again it renders perfectly smooth without locking up.

Yes, i was referencing to the "Save Buffers" from the Performance panel of the render settings.

I didn't get "lock up blender too". Original report was about crash, not about locking?

With "Save Buffers" deselected I get only locking but it renders fine.
Without "Save Buffers" I get more aggressive locking of the whole pc but no crash.

I guess this one can be marked fixed based on build 0c5eb88 I have tested now.

:) Happy programmering guys!

Sergey Sharybin (sergey) closed this task as Resolved.Dec 18 2014, 11:19 AM
Sergey Sharybin (sergey) claimed this task.

Locking might be caused by much more intense memory usage.

But as long crash doesn't happen anymore, would consider the issue fixed. Please let us know if it strikes you back.