Page MenuHome

Environment maps cause a hard crash with OSL enabled
Closed, ResolvedPublic

Description

System Information
Windows 8.1 Pro

Blender Version
Broken: 2.71 final, 2.71 RCs
Worked: unknown

Assigning World an Environment Texture results in a hard crash at render time (no crash log, no debug information in the console).

Exact steps for others to reproduce the error

  1. Open default scene
  2. Enable Open Shader Language
  3. Add shader nodes to World Surface
  4. Assign Background to World Surface shader
  5. Assign an Environment Texture to Background
  6. Hit Render (or change the Viewport Shading to Rendered)

Tested and confirmed to occur with EXRs and JPGs.
Not tested with TIFFs.

Test scene:

Details

Type
Bug

Event Timeline

Ante Vukorepa (orcinus) set Type to Bug.
Ante Vukorepa (orcinus) created this task.
Ante Vukorepa (orcinus) raised the priority of this task from to Needs Triage by Developer.

The test EXR texture is packed in the file.
Just tested this in Blender 2.70a for Mac OS X and it works fine there.
Will test on 2.71 for Mac OS as well as 2.70 for Windows.

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

Can confirm crash with current master on linux64 as well :/

Does not crash on 2.71 Mac OS.
Does not crash on 2.70a Windows x64.

CRASHES on 2.70a Windows x64 VC2013 preview.

Sergey Sharybin (sergey) lowered the priority of this task from Confirmed, Medium to Needs Information from User.

The crahs of current master and packed image has been fixed. However, it's a crash on a new code which was added after 2.71 release in order to support packed images render.

Original report about crash crash of 2.71 i can not reproduce neither on linux nor on windows7. Could be something really platform-dependent like T40884.

@Thomas Dinges (dingto), @Martijn Berger (juicyfruit), are you able to reproduce crash?
@Ante Vukorepa (orcinus), are you able to reproduce the crahs NOT using packed images with latest builds from builder.blender.org?

@Sergey Sharybin (sergey) The crash occurs with or without packed images. In fact, i can just leave an empty Image Texture node (without a texture loaded) connected to a shader and it will still crash.
Downloading buildbot version(s) now, will report when i test.

Just FYI, i have a strong hunch this is an interaction between Windows 8(.1) and VC2013.
If true, that might mean @Bastien Montagne (mont29)'s linux reproduction is something else.

blender-2.71-4299b00-win64 - CRASHES
blender-2.71-81c3fc9-win64-vc9 - DOES NOT crash

By the way, note that T40884 reproduction wasn't really undertaken correctly.
The original bug was reported on Windows 8.1 (hint hint), while the OP's resolution was:

but on my main Blender station, a Windows 7 64-bit desktop with a GTX 580 GPU, the same Blender version under the same conditions does not crash

So, once again... Strong hunch this has to do with VC2013 under Windows 8(.1).

In case this helps, here are the Event Viewer crash dumps:

Faulting application name: blender.exe, version: 2.7.1.0, time stamp: 0x53ba01cb
Faulting module name: blender.exe, version: 2.7.1.0, time stamp: 0x53ba01cb
Exception code: 0xc0000005
Fault offset: 0x0000000000e5460a
Faulting process id: 0x3f94
Faulting application start time: 0x01cf99f1bb9699cd
Faulting application path: C:\Users\Ante Vukorepa\Downloads\blender-2.71-4299b00-win64\blender-2.71-4299b00-win64\blender.exe
Faulting module path: C:\Users\Ante Vukorepa\Downloads\blender-2.71-4299b00-win64\blender-2.71-4299b00-win64\blender.exe
Report Id: 29c9dd68-05e5-11e4-82bc-a7a4915d524a
Faulting package full name: 
Faulting package-relative application ID:

Fault bucket 85940633048, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: blender.exe
P2: 2.7.1.0
P3: 53ba01cb
P4: blender.exe
P5: 2.7.1.0
P6: 53ba01cb
P7: c0000005
P8: 0000000000e5460a
P9: 
P10: 

Attached files:
C:\TempTemp\WER9FD7.tmp.WERInternalMetadata.xml

These files may be available here:
C:\Users\Ante Vukorepa\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_blender.exe_cff221b631569d13a3dc194097c173d2abe88c6_3918f389_2acfa5b3

Analysis symbol: 
Rechecking for solution: 0
Report Id: 29c9dd68-05e5-11e4-82bc-a7a4915d524a
Report Status: 1
Hashed bucket: 46621339fb80236b57f59351b166c6d4

WER file:

I've committed some fixed at rB5e216a6. Please grab a build which includes this commit and give it a test.

Unsure how to check which build contains commits up to what, but if blender-2.71-5e3e095-win64 contains it, the problem is still there.

This build contains the fix i was referring to. Can not reproducethe crash atm tho.

@Thomas Dinges (dingto), @Martijn Berger (juicyfruit), mind having it a try?

I cannot reproduce the crash on a virtual machine where AVX is turned of even with 2.71 release.

I am thinking llvm as the real culprit

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Jul 20 2014, 10:09 AM

I'll merge T41123 in here since root of the issues are likely goes to the same thing.

Sergey Sharybin (sergey) lowered the priority of this task from Normal to Needs Information from User.Aug 7 2014, 9:27 PM

Please test whether latest builds from builder.blender.org. We've upgraded both LLVM and OSL, this might have solved the issue.

Works fine now on OSX 10.9 for both this blend file and one from T41123.
Thanks.

Sergey Sharybin (sergey) closed this task as Resolved.Aug 8 2014, 3:34 PM
Sergey Sharybin (sergey) claimed this task.

Will assume the issue fixed now for everyone. @Ante Vukorepa (orcinus) lemme know if it still happens for you.

@Jennifer Godin (jenniferblender) Mac OS never exhibited the bug.

@Sergey Sharybin (sergey) Will retest in a few weeks (stuck on an island without access to my Windows desktop) and report back if it's still broken.

@Ante Vukorepa (orcinus) Yes, it did if you read the bug I reported at T41123 which was merged with this one. :)

Ah, gotcha, sorry :)
Didn't experience that one.

Ante Vukorepa (orcinus) added a comment.EditedAug 30 2014, 11:48 PM

Issue has not been fixed.

Tested with blender-2.71-526ae63-win64, same scene as posted in the original report, still crashes when you hit render or switch viewport shading to rendered.

(on Windows 8.1, as in the original report)

@Ante Vukorepa (orcinus), so far we can not reproduce the issue. Did you try reproducing the issue on another computer?

Yes i did.
i7 laptop (Asus Taichi) running Windows 8 (not .1) x64.

Exact same behaviour.
Have you tried reproducing it on Windows 8 (NOT 7)?