Page MenuHome

Blender Crashes, Causes Unity to Crash
Closed, ArchivedPublic

Description

System Information
MacBook Pro Retina 2.6 GHz 2012
Blender 2.71

Blender crashes whenever I try to export any format except .obj. Also, last week I was importing objects with 1.6 million plus vertices into Unity from Blender, with no problem. Now, anything with more than like 1 thousand vertices crashes Unity, and Blender can only handle .obj and .blend, no other format.

Try to export other formats, or try to get super high poly objects into Unity, to reproduce the error. I'm using the latest versions of both Blender and Unity.

Details

Type
Bug

Event Timeline

JJ (JJDeveloper) updated the task description. (Show Details)
JJ (JJDeveloper) raised the priority of this task from to Needs Triage.
JJ (JJDeveloper) added a project: BF Blender.
JJ (JJDeveloper) set Type to Bug.
JJ (JJDeveloper) added a subscriber: JJ (JJDeveloper).
Bastien Montagne (mont29) closed this task as a duplicate.Jul 16 2014, 11:39 AM

✘ Merged into T40907.

Sorry, not same issue actually

Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 16 2014, 11:43 AM

Tssst… First of all, if Unity crashes, it’s a Unity bug, not a Blender bug!

Further more, we need a file you are trying to export, and which crashes Blender.

Third, Blender supports tens of other export formats, like FBX, DXF, collada, whatever…

It actually may not be a Unity bug if something is corrupting the file in Blender, which in turn is crashing Unity. Furthermore, FBX crashes Blender on its own.

We can keep talking about that endlessly, if we do not have a file to check…

Sergey Sharybin (sergey) closed this task as Archived.Jul 21 2014, 12:06 PM
Sergey Sharybin (sergey) claimed this task.

5 days without reply. We can not fix bugs which we can't reproduce. And to reproduce the crash we need as small as possible file demonstrates the crash with minimal steps to crash.

For until this info is provided archiving the report.

It is fairly simple to reproduce this issue. Just place a .blend file in a Unity folder and see how it crashes. This seems to be cause by Python as described here:
http://forum.unity3d.com/threads/blender-2-71-blend-to-unity-broken.254632/#post-1700044

@Bastien Montagne (mont29), thanks for pointing me to the correct one!