Page MenuHome

Mesh geometry can not be edited - cant move vertices
Closed, ArchivedPublic

Description

System Information
manjaro linux 64 bit,

Blender Version
Broken: 2.71 - hash 9337574
blender-2.71-5e4a97d

Short description of error
Blender 2.71 - hash 9337574 corrupts blend file. Mesh geometry becomes ineditable.
After working on this mesh for half an hour, it suddenly became ineditable.

Exact steps for others to reproduce the error
1.open the file attached to this report

  1. Select the boy if he's not already selected and try moving vertices in edit mode, try it in sculpt mode. Nothing happens. Mesh can not be edited.

Blender corrupted it.

  1. Select some of the other layers to find his bag- try editing it - works

Details

Type
Bug

Event Timeline

Todor Imreorov (blurymind) created this task.
Todor Imreorov (blurymind) raised the priority of this task from to Needs Triage by Developer.

Bastien, seems funny one, mind having a look? :)

Sergey Sharybin (sergey) triaged this task as Normal priority.Jul 31 2014, 3:49 PM

There is a basis shapekey on mesh. When there are shapekey; you can edit only the active one.
So, you select one and then edit it.

I don't know why but in this blend basis shapekey is active without being really selected.
So, if you select basis shapekey; you are be able to edit it.

So changes made to the mesh(which are not showing up) all become visible when new geometry is added, this gives the impression that it's the Viewport which is not receiving updated info until new geometry is added.

Here I made several individual changes to the mesh by selecting and moving vertices one at a time(even though the movement did not show), 9 times in total. After moving the 9th vertex, I added a plane and then all 9 Grab operations were simultaneously rendered to the screen. I marked off all the Grab operations that I performed on the mesh.

EDIT: there is something else going on here that can't be explained by what I said above. When I return to Object mode, all the changes I made disappear, including the plane which I added. When returning to Edit mode, the mesh looks the same as when I first loaded the .blend.

I looked at the shape key based on what zeauro said. Clicking it returns Edit mode functionality back to normal and shows more options for the shapekey that were not visible before.

Bastien Montagne (mont29) lowered the priority of this task from Normal to Needs Information from User.Jul 31 2014, 6:02 PM

Well… the bug here is having a selected yet not active skey. I’m afraid if you can’t provide us with precise steps to reproduce such situation, we can't do much… :/

i appended his hands and feet from other (older) models (i had) who had shape keys on them. I duplicated a part of the mesh (hands and feet) , separated it, cleared the shape keys and then appended it to use on the kid.

Is there some possible way to get around this? Clean up the mesh somehow?

Maybe export and reimport it?

EDIT: nevermind, deleting the basis shapekey fixed the issue!
It was definitely weird though. Sorry I could not provide more information

Bastien Montagne (mont29) closed this task as Archived.Aug 2 2014, 1:11 PM

Closing as archived for now, since seems we can't easily reproduce that bug… Thanks for the report anyway. :)

Deterring this one as there is still a bug in 2.79b:
Just got a similar issue using Manuel Bastioni character generation.
Thanks for pointing to the shape keys. Shapekey is not selected by default in my case, so grabbing a vertex is not visible in edit mode but applied and visible when switching to object mode. Once shape key is chosen it is fixed:
https://youtu.be/qKm3c89EDGM

The bug (or I missed something):
Shapekey to 1, then un-tick apply shapekey at edit mode, set it to zero, re-tick apply to edit mode, it is still at one in edit mode. Whatever yo udo you're stuck, an eye closed in my case :)
https://youtu.be/sxmulxgLnds

Sorry, I forgot to ask for action