Page MenuHome

Node groups doesn't update on frame change
Closed, ArchivedPublic

Description

System Information
Ubuntu 64 14.04

Blender Version
Broken: Blender 2.71 (7ef9257)

Short description of error


Transparency is animated inside Node Group for two materials, but it doesn't get updated on frame change.

Details

Type
Bug

Event Timeline

David Gascueña (netich) raised the priority of this task from to Needs Triage by Developer.
David Gascueña (netich) updated the task description. (Show Details)
David Gascueña (netich) set Type to Bug.

Confirmed, looks like a missing update in case of groups? Or maybe a bit more tricky… Sergey, another one for you I guess.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Aug 23 2014, 3:14 PM
Sergey Sharybin (sergey) closed this task as Archived.Aug 27 2014, 11:35 AM

This is a dependency graph limitation. It might be solved with the current one, but it'll introduce loads of false positive updates in the viewport. And that's not the only issue with the animation in the node groups.

Thanks for the report, but it's a known TODO.