Page MenuHome

Blender crashes when using webcam in VideoOnTexture.
Closed, ArchivedPublic

Description

System Information
Ubuntu 14.04, x64
Genius Webcam VideoCam NB (an oooold one)

Blender Version
2.71 stable

Short description of error
Following instruction in this page http://seanwasere.com/?p=115 (blend file is from this page), I enter in Game Engine and Blender crashes.

This is what "--debug-all" says: http://www.pasteall.org/53686

Exact steps for others to reproduce the error
Connect a webcam (/dev/video0), open the file and enter in Game mode.

Details

Type
Bug

Event Timeline

Mario Mey (mariomey) set Type to Bug.
Mario Mey (mariomey) created this task.
Mario Mey (mariomey) raised the priority of this task from to Needs Triage by Developer.

Did you change the script in the file to point to your webcam? is he is using what works for him in windows.

Check the official instruction on using the feature here http://www.blender.org/documentation/blender_python_api_2_67_1/bge.texture.html

There is also a thread on BA that might have some pointers for you. http://blenderartists.org/forum/showthread.php?255206-webcam-player

In the same situation, using the file from the thread, Blender crashes too.

I don't have another webcam, but I have an EasyCam that it is not tested. It only takes /dev/video1 but, as I don't have Composite cables and an analog input, I can't test with image. Buuuut... with this input, Blender doesn't crash.

The webcam is an old one, but it works OK. Maybe it is a webcam compatibility problem...

v4l-info throw me this about this camera: http://www.pasteall.org/53696

2.64 - 2.65 - 2.66 this: http://www.pasteall.org/53698
2.67 - 2.68- 2.69 - 2.70 this: http://www.pasteall.org/53697
2.71 CRASH.

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

Can not reproduce this with 2.74 and current builds from buildbot. Do you mind testing if new versions are still crashing for you?

Yes, this happens in 2.74.

IMPORTANT INFO: the camera that is crashing Blender is a very old one: Genius VideoCAM NB. With Cheese (Linux app), it works. But it has so bad quality... that I maybe throw it to trash.

I don't really know if it is necessary to mantain this report open. As I told before, I tested with an EasyCam capture device and it worked OK. Now, I just tested with a Logitech webcam and it works OK, too.

I suggest to close this report.

Sergey Sharybin (sergey) closed this task as Archived.May 18 2015, 7:45 PM
Sergey Sharybin (sergey) claimed this task.

Ok, since it's hardware related issue will archive the report for until some developer will manage to redo the issue.

P.S. Instead of trashing it you can send it to BGE developers so they investigate if we can solve the crash :)

We can ask in bge-list if someone has an old webcam to test it...

I'm doing it right now.