Page MenuHome

Movie Clip Editor's timeline allows scrubbing beyond the editor area
Closed, ArchivedPublic

Description

System Information
OS X 10.8.5
ATI Radeon HD 4850 512 MB

Blender Version
Broken: 2.71 9337574 (2.72 test build)

Short description of error
In the Movie Clip Editor a clip can extend beyond the area of the editor. So if you click the purple timeline and drag all the way to the right the Time Cursor goes under the Properties Shelf and under whatever area is to the right of that (the Properties Window by default). This seems unintentional, because after releasing the mouse button the Time Cursor will be on a frame you can't see or access unless you go to the Timeline editor.

If you don't have a workspace area set up for the Timeline editor or if you are in full screen mode you've just lost track of your Time Cursor. But even if you can still navigate using the Timeline it's just weird that the Time Cursor can go out of range like that.

Wouldn't it make more sense if the full clip duration corresponded with the full pixel span of the purple timeline bar?
Sure, this width will change as the window/area size is adjusted, and change as the Properties Panel is hidden/shown but that happens anyway.
With long clips there may not be enough pixels to represent each frame, but maybe holding shift for scrubbing in finer increments would address that.
I don't want to turn this into a feature request, just point out that it's awkward for the Time Cursor to go underneath part of the interface.

Here is a random .mov you can load up to test this if you don't have one handy:

Exact steps for others to reproduce the error

  1. Open the Movie Clip Editor
  2. Open a movie clip
  3. Click the purple timeline, drag to the right as far as you can, and watch the Time Cursor become obstructed from view

Details

Type
Bug

Event Timeline

Seth L. (quantumanomaly) set Type to Bug.
Seth L. (quantumanomaly) created this task.
Seth L. (quantumanomaly) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.Sep 17 2014, 5:11 PM
Sergey Sharybin (sergey) claimed this task.

Well, that's actually pretty close to what's happening in the timeline -- you can drag the current frame out of the visible range there as well (with the only difference of continuous grab). It's actually quite useful to see clip outside of the scene frame range.

Thanks for the report, but it's not a bug, just intended behavior to cover some usecases.

I agree it might be confusing. Then again, the timeline behaves similar, following the continuous grab behavior in Blender. On top of that I find it very handy to be able to check out what's beyond the frame range. For example if you're tracking huge 5k openEXR footage you gotta track in chunks, in which case it helps to work with shorter frame ranges and then glue the separate parts together. And there it is great to be able to scrub beyond the frame limit to check for continuity.
So no, this is not a bug, it's a feature!
:)