Page MenuHome

2.72 testbuild: Cycles crush when I set emission as volume material for world.
Closed, ArchivedPublic

Description

Windows 7 64
GTX 460 drivers 335.23

B 2.72 testbuild d919218

Blender will crush if emission (diffuse etc) will be set as volume in World settings (Cycles). It's broken only on GPU. It's broken only in 3d view - rendering by F12 don't crush.
http://wstaw.org/w/2Xof/
http://wstaw.org/w/2Xoh/

Open file


Be sure that GPU is set as device
Press Shift+Z and enjoy

Details

Type
Bug

Event Timeline

Piotr Załóg (piotr) set Type to Bug.
Piotr Załóg (piotr) created this task.
Piotr Załóg (piotr) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.Sep 22 2014, 4:49 PM

In my tests i'm having a timeout error happening in cuCtxSybchronize caused by the fact that CUDA limits time which kernel might spend on the computation if it's running on your display GPU. In some cases you can work this around my using smaller tile size or increase the timeout. Some more details you'll find there http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering#CUDA_error:_Unknown_error_in_cuCtxSynchronize.28.29

Really annoying thing here is that windows might just restart the video driver, killing all the applications which uses it, so blender will have no chance handling it. That said sometimes i do see timeout error reported by blender, sometimes not. That's on windows, on linux all the issues are reported just nicely.

So, thanks for the report, but it's just a limitation of CUDA architecture combined with some fuunkyness happening in windows drivers..