Page MenuHome

GPU render not working with Nvidia GTX 970
Closed, ResolvedPublic

Description

System Information
Windows 7 Service Pack 1 64-bit
Nvidia GTX 970
Nvidia driver version 344.11

Blender Version
Broken: 2.71 9337574

Short description of error
CUDA binary kernel for this graphics card compute capability (5.2) not found.

Exact steps for others to reproduce the error
Using a GTX 970 card, select GPU compute in cycles and then press SHIFT+Z in the 3D window to switch to a rendered view. See error message.

Notes
I installed the CUDA toolkit 6.5 and all the CUDA sample programs run fine.

Details

Type
To Do

Event Timeline

Carmen Wick (fezmonkey) set Type to Bug.
Carmen Wick (fezmonkey) created this task.
Carmen Wick (fezmonkey) raised the priority of this task from to Needs Triage by Developer.
Thomas Dinges (dingto) changed Type from Bug to To Do.Sep 23 2014, 1:49 PM

We don't support sm_52 yet, this is too late for Blender 2.72. We will update afterwards, so the daily builds + Blender 2.73 will support it.

Thomas Dinges (dingto) triaged this task as Normal priority.Sep 23 2014, 1:55 PM

Where are the daily builds? I can't find anything to make this GTX 980 render without blackscreening

We have not updated the Buildbot yet. For now you can rename the sm_50 kernel to sm_52, then it will work.

You can find them in your Blender installation under 2.72\scripts\addons\cycles\lib

@Thomas Dinges (dingto) isnt it possible to rename the sm_50 file to sm_52 and get it to work?

That's what I just wrote. :P

I already tried that and no matter what I do it black screens if it's more than a single cube. And it shouldn't be capping the memory as the scenes I'm trying to render take under 300MB to render and the card is 4GB.

Just keeps giving an error 3 message.

lol sorry i was on this page at least 10 min before i posted. I had to make sure what i was saying was right (do some googling) :D im guessing it doesn't auto refresh ;)

Oh, wow, that was a simple fix :) I renamed sm_50 -> sm_52 and it worked. No issues using it in my scenes so far.

fezmonkey> Hi can you please render this. Write how many seconds it took.
Blend
Preview JPG
On GTX TITAN 51,63s

This is not an internet forum here. Please keep off-topic out of this thread. Thanks.

I made a cuda test scene and it doesn't crash with glossy, antisotropic, glass, diffuse, and felt. along with a image background. But I go to render a model I made and it renders fine until half way and then error 3 flags up and I loose the render. I'm thinking it might be some transparent textures, but it renders them both fine for most of the scene, the part that it stops on doesn't seem to have any new materials in it so it shouldn't be a shader issue. and the scene is only 300MB.

Was actually having some hope this morning and then I go to actually use it and bummer.
And it seems that renaming the 5.0 kernel is really poor in optimization (which makes sense) as it only makes my GTX 980 4.73x faster than an i5-3570k, which is good just not great.

Wouldn't it be awesome if somehow cycles made use of VXGI some time in the future!

Thomas Dinges (dingto) closed this task as Resolved.Oct 11 2014, 8:26 PM
Thomas Dinges (dingto) claimed this task.

There is a workaround in Cycles now, it will automatically use the sm_50 kernel.

Last time I tried a unofficially supported kernel it almost gave me a heart attack getting me stuck on a bios splash screen. I really wondering if I should just return my card and wait for an 8GB version or something, though I don't think it's a vram issue per say, as that would just give an error message inside blender, not cause crashes and immediate blender closures.

Now that Blender 2.72a is out, I hoped it would have support for sm_52 but it doesn't? Any reason for that?

The GTX 9xx cards are supported in the buildbot builds (builder.blender.org).

An "a" release is a bugfix release, support for a new GPU generation is not a bugfix, but a feature.

Fair enough, just seemed like a good opportunity, new feature or not.

I currently built a new pc. Using an Asus Z87-A LGA 1150 with a i7-4790K and a Nvidia Geforce GTX 970. So far the only version of Blender I can get to open is 2.69a everything after that crashes on launch. I'm not sure if it's the GPU, but any advice would be helpful.

I take that back, i downloaded 2.72a 32 bit and that opened fine. But I'm currently running a 64 bit OS

Anyone have success with the GTX 9xx series? My fiancee has managed to render some simple things just fine but recently she's tried to render grass and the graphics drivers crash entirely. If nothing works currently is there a timeline for official support?

The card is supported. If there is an issue (like driver crash), please make a new report with all relevant information. Maybe you run out of memory or the GPU was taking too long, and the OS triggered an time out..