Page MenuHome

uv map resets when joining objects
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
OS: Winodws 7 pro 64bit
GPU: NVIDIA Quadro K4000 (340.62)

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
official 2.71 and 2.71.6 6480fdc
Worked: (optional)

Short description of error
when joining the 2 objects in the attached blend

file then one of the meshes will loose the uv information for some reason.
the objects were appended from their main scenes so maybe something happen there which causes the object to loose the uv when joined with an other one.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. open the blend file
  2. look at the uv maps from each of the objects to remember how they should look when combined
  3. go back into object mode and join the 2 objects with crtl+j
  4. look at the uv map again, notice that one of the uvs is compressed to the bottom left corner of the uv

Details

Type
Bug

Event Timeline

dan grauer (kromar) set Type to Bug.
dan grauer (kromar) created this task.
dan grauer (kromar) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) claimed this task.

No bug here, CD layers are now joined by name, and since your two UV maps do not have the same name, you get two UVMaps in resulting mesh. Thanks for the report anyway.

Please is it possible to merge UV maps by index again, or add button to select the option (merge by name/index)? I work with sketchup models, where is about 6000 uvmaps in one model, and each has unique name ID0 ... ID6012. It can't be merged manually. Thanks for your reaction.