Page MenuHome

Cycles ID pass (Objekt and Material) Bug.
Closed, InvalidPublic

Description

System Information
Win 7 64Bit - GTX 650

Blender Version
Blender 2.71
Hash: 9337574
25.06.2014

Since there is on no roadmap, an indication that this bug shall fixed ... Here a reminder!

The ID pass has no grayscale values, that makes it unusable for compositing.

Any Workaround (e.g emission material override) is really a bit frustrating and time consuming.

http://blenderartists.org/forum/showthread.php?342262-Cycles-ID-mask-looks-low-sample

It must be possible (however), to create a clean black and white mask otherwise the Cycles ID passes are useless.

Please Devs, fix this existentially feature!


Screenshot

PSD packed with 7z

Blend

Details

Type
To Do

Event Timeline

Hans Nolte (ditos) updated the task description. (Show Details)
Hans Nolte (ditos) raised the priority of this task from to Needs Triage by Developer.
Hans Nolte (ditos) added a project: BF Blender.
Hans Nolte (ditos) set Type to Bug.
Thomas Dinges (dingto) changed Type from Bug to To Do.Sep 23 2014, 4:28 PM

This bugtracker is *not* for feature requests. Therefore I set this to a ToDo task now.

And as already noted by someone in the Blenderartists thread, the missing AA comes from the fact, that the ID passes are only rendered with 1 sample.

Thomas Dinges (dingto) triaged this task as Confirmed, Low priority.Sep 23 2014, 4:31 PM
Thomas Dinges (dingto) closed this task as Invalid.Sep 23 2014, 4:36 PM

Actually, this is intended behaviour: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/Passes

"The Z, Object Index and Material Index passes are not antialiased. This is done because such values can't really be blended correctly. "

Thanks Thomas to set this to a ToDo task.