Page MenuHome

texture painting crash
Closed, DuplicatePublic

Description

System Information
winxp 32 bits

Blender Version
Broken: blender-2.71-8837bb2-win32 , blender-2.71-d7ddb94-win32
Worked: Blender 2.71 "stable"

Short description of error
while accidentally pressing Z while being in texture paint mode on a buildbot version i was using, Blender crashed to desktop, i then downloaded today build , and similar.

Exact steps for others to reproduce the error

  • Launch Blender
  • Make sure it's factory settings
  • Go to Texture Painting mode (Blender will assign automatically a material to default cube)
  • Press Z
  • Crash

Didn't happened in Blender 2.71 "stable" as i just checked, can't say when it started to happen as i never press Z in texture painting mode usually

Does not crash if i switch to "Cycles Render", it only happens with default factory settings (and so Blender Render mode)

Details

Type
Bug

Related Objects

Event Timeline

Sanc Tuary (sanctuary) set Type to Bug.
Sanc Tuary (sanctuary) created this task.
Sanc Tuary (sanctuary) raised the priority of this task from to Needs Triage by Developer.

Antony, mind checking on this one? Thanks! :)

Sergey Sharybin (sergey) triaged this task as Normal priority.Sep 24 2014, 10:03 AM

Can't reproduce on ubuntu 14.04 NVIDIA Quadro 2000 or on windows 7 64bit.
The OS is old of course but this shouldn't matter so much in theory...
Graphics card info can always help here. Can you paste the contents of system_info please?

The very odd thing is that it does not crash on Cycles
Here it is :

Blender 2.71 (sub 6) System Information

Blender:

version 2.71 (sub 6), branch b'master', commit date b'2014-09-22' b'09:01', hash b'd7ddb94', b'Release'
build date: b'2014-09-23', b'03:04:28'
platform: b'Windows:64bit'
binary path: 'C:\\blender-2.71-d7ddb94-win32\\blender-app.exe'
build cflags: b'-DWITH_FREESTYLE /nologo /J /W3 /Gd /w34062 /wd4018 /wd4065 /wd4127 /wd4181 /wd4200 /wd4244 /wd4267 /wd4305 /wd4800 /we4013 /we4431 /DOIIO_STATIC_BUILD /openmp -O2 /Ob2 -DWIN32 -D_CONSOLE -D_LIB -D_CRT_SECURE_NO_DEPRECATE -DOPJ_STATIC -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN -DWITH_AUDASPACE -DWITH_AVI -DWITH_OPENNL'
build cxxflags: b'/nologo /J /W3 /Gd /w34062 /wd4018 /wd4065 /wd4127 /wd4181 /wd4200 /wd4244 /wd4267 /wd4305 /wd4800 /we4013 /we4431 /DOIIO_STATIC_BUILD /openmp /EHsc -O2 /Ob2 -DWIN32 -D_CONSOLE -D_LIB -D_CRT_SECURE_NO_DEPRECATE -DOPJ_STATIC -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN -DWITH_AUDASPACE -DWITH_AVI -DWITH_OPENNL'
build linkflags: b'/SUBSYSTEM:CONSOLE /MACHINE:IX86 /STACK:2097152 /INCREMENTAL:NO /LARGEADDRESSAWARE /NODEFAULTLIB:msvcrt.lib /NODEFAULTLIB:msvcmrt.lib /NODEFAULTLIB:msvcurt.lib /NODEFAULTLIB:msvcrtd.lib'
build system: b'SCons'

Python:

version: 3.4.1 (default, Aug 29 2014, 15:47:12) [MSC v.1800 32 bit (Intel)]
paths:
'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\addons_contrib'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\addons'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\startup'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\modules'
'C:\\blender-2.71-d7ddb94-win32\\python34.zip'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\python\\DLLs'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\python\\lib'
'C:\\blender-2.71-d7ddb94-win32'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\python'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\python\\lib\\site-packages'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\freestyle\\modules'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\addons\\modules'
'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\addons\\modules'

Directories:

scripts: ['C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts']
user scripts: 'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts'
pref scripts: None
datafiles: 'C:\\blender-2.71-d7ddb94-win32\\2.71\\datafiles\\'
config: 'C:\\blender-2.71-d7ddb94-win32\\2.71\\config\\'
scripts : 'C:\\blender-2.71-d7ddb94-win32\\2.71\\scripts\\'
autosave: 'C:\\blender-2.71-d7ddb94-win32\\2.71\\autosave\\'
tempdir: 'C:\\DOCUME~1\\Usename\\LOCALS~1\\Temp\\blender_a01456\\'

FFmpeg:

'avcodec':' ''55, 39, 101'
'avdevice':' ''55, 5, 100'
'avformat':' ''55, 19, 104'
'avutil':' ''52, 48, 101'
'swscale':' '' 2, 5, 101'

Other Libraries:

OpenColorIO: 1, 0, 8
OpenImageIO: 1, 4, 12
OpenShadingLanguage: 1, 5, 10

OpenGL

renderer: 'Intel(R) G41 Express Chipset'
vendor: 'Intel'
version: '2.1.0 - Build 6.14.10.5420'
extensions:

		'GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color'
		'GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint'
		'GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp'
		'GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod'
		'GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp'
		'GL_EXT_separate_specular_color GL_ARB_multitexture'
		'GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate'
		'GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add'
		'GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_texture_env_add'
		'GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays'
		'GL_NV_blend_square GL_ARB_texture_compression'
		'GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic'
		'GL_ARB_texture_border_clamp GL_ARB_point_parameters'
		'GL_ARB_texture_env_combine GL_ARB_texture_env_dot3'
		'GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc'
		'GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs'
		'GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle'
		'GL_ARB_fragment_program GL_EXT_stencil_two_side'
		'GL_ATI_separate_stencil GL_ARB_vertex_buffer_object'
		'GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader'
		'GL_ARB_shader_objects GL_ARB_shading_language_100'
		'GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader'
		'GL_NV_texgen_reflection GL_ARB_point_sprite'
		'GL_EXT_blend_equation_separate GL_ARB_depth_texture'
		'GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float'
		'GL_ARB_half_float_pixel GL_ARB_texture_float'
		'GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object'
		'GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_EXT_draw_buffers2'
		'GL_WIN_swap_hint GL_EXT_texture_sRGB GL_EXT_packed_float'
		'GL_EXT_texture_shared_exponent GL_ARB_texture_rg'
		'GL_ARB_texture_compression_rgtc GL_NV_conditional_render'
		'GL_EXT_texture_swizzle GL_ARB_framebuffer_sRGB'
		'GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float'
		'GL_EXT_transform_feedback GL_EXT_framebuffer_blit'
		'GL_ARB_framebuffer_object GL_ARB_vertex_array_object '

Implementation Dependent OpenGL Limits:

Maximum Fixed Function Texture Units: 8

GLSL:
Maximum Varying Floats: 41
Maximum Vertex Attributes: 16
Maximum Vertex Uniform Components: 512
Maximum Fragment Uniform Components: 1024
Maximum Vertex Image Units: 16
Maximum Fragment Image Units: 16
Maximum Pipeline Image Units: 16

little update, i managed to get a friend with the same OS but with a ATI Radeon HD4850
And when he press Z in texture paint mode while in Blender Render, it does not crash for him.
If i switch to bounding box instead of pressing Z , same crash, other display mode works correctly (still will not crash if i am in Cycles render mode instead of Blender render mode)

Though, similarly to what i observe in the case i switch to Cycle (in which case for reason i don't see, it does not crash and behave correctly) , he see the default cube being flat shaded textureless, instead of seeing wireframe (Z being the wireframe mode shortcut).
Not sure if it's linked to the problem.

Was your friend's OS 32 bit? We have a duplicate report actually.