Page MenuHome

Snapping to grid bug in 2.71
Closed, ArchivedPublic

Description

System Information
Windows 7 64 Bit, Gefore GTX770

Blender Version
2.71

Short description of error
Snap to Increment seems to fail after second usage in both Object and Edit mode

Exact steps for others to reproduce the error
Load factory defaults; Select Top Ortho view; Select Snap to Increment;
Scale cube uniformly by 1.5; Any subsequent scaling does not snap to appropriate grid line, unless very zoomed in

(many apologies if I misunderstood... fairly new user!)

Details

Type
Bug

Event Timeline

michael lock (mikeyj21) created this task.
michael lock (mikeyj21) raised the priority of this task from to Needs Triage by Developer.

This sounds like a misunderstanding of how increment snapping works in Blender. It doesn't snap to an overall grid, rather, it limits the transform to increments. So when scaling with snap enabled, it will scale by 1.5 and not by 1.57269 and it won't mind about the grid at all. The actual transform is constrained, not the end coordinates of an element. It works the same when translating or rotating.

Snapping to an overall global grid doesn't exist in Blender, but it's been mentioned a few times. I'd like to see it included as well :) but that's already a feature request and not a bug.

Sergey Sharybin (sergey) closed this task as Archived.Sep 25 2014, 9:50 AM
Sergey Sharybin (sergey) claimed this task.

@Matjaž Lamut (lamoot) actually explained it all already, it's an incremental snap. Snapping to a "global" grid is not there and this is not considered a bug.

In any case thanks for the report!