Page MenuHome

Blender crash after rendering 2.72
Closed, ResolvedPublic

Description

Windows 7
Asus k95v laptop
CPU i7 octocore
Nvidea Geforce GT 630M

Broken Blender Version
Blender c68c32a
Worked worked in 2.71

Error:
Well let me be clear first i didnt render using GPU in my case thats to slow
I always render on CPU as i got an octo core i7 36100M 2.3 ghz CPU
Still i got the error below :

The Nvidea OpenGL driver lost connection with the display driver due to exceeding the windows time-out limit and is unable to continue

While I am 100% sure i did not use GPU for rendering, (i had 8 render blocks during rendering).

Exact steps are a bit hard it seams to happen with larger render files and higher render quality, so there isnt a quick reproduce here.
At the moment it happened i was sleeping so i didnt saw the exact moment either.

I'd like to notice that i have crashes on rendering since 2.72, with files that worked fine in 2.71
It got problems to with the offical 2.72 release candidate as mentioned in this thread :
http://blenderartists.org/forum/showthread.php?349962-Blender-rc2-crashing-at-the-moment-render-finishes

Details

Type
Bug

Event Timeline

Peter Boos (PGTART) set Type to Bug.
Peter Boos (PGTART) created this task.
Peter Boos (PGTART) raised the priority of this task from to Needs Triage by Developer.

An additional comment since i had a Compositing setup to write the result to my c:\tmp folder
And i didnt found any result there, i think still the rendering itself didnt finish to the end, might be close related to the problem as i mentioned in the link although then i didnt got nvidia problems then, but like then the rendering process started fine, when i went sleeping 1/3 (one third) had been rendered fine then, the process was still going on.

Hmmm… Making a report based on a single case is not really useful, first because we need something reproducible to investigate, and second, because it makes a random OS/Driver/Hardware failure highly possible. Especially on a laptop, that hardware is not designed to work under heavy loads during a whole night!

What you should do to better understand the core of the issue:

  • Ensure this is reproducible (i.e., even if it does not happens each time, that it does reasonably often to be sure it’s not an hardware/OS/etc. failure).
  • Check what happens if you limit render threads to e.g. 6, so that you do not monopolize all of your computing power.
  • Monitor temperatures! Both CPU and GPU ones.
  • Monitor memory usage.

Will add other devs too, to see whether they have better ideas here…

I doubt that hardware is the issue here, since i wasn't rendering on GPU, and blender was just tiling the final render, and it has been doing fine for the start of the render job but didn't finish to the (final?) end. > i say final because that seamed to be the problem as i mentioned earlier in the blender artist thread.

This laptop is perfectly OK running 100% CPU loads for several days without any heating problems, i bought it for movie editing mainly and its fine with blender too. I have try-ed to run Blender using less threads before, as written in the blender artist thread link, i tend to think it has to do with the finishing of the render job (threads) with large high level renders. Smaller render jobs seam to be working.

On a side note i'm a bit confused of why i got a Nvidea error while i wasnt rendering on GPU.
Since i never use GPU for rendering..

What i will also check since the laptop has two video cards, i will try to set the computer to run this software using the onboard video card. (despite i never choose to use GPU inside blender) This would disable nvidea opengl driver i think, but then possible be havoc on the other card .. i'll check it later this week since i also need to work on it.

I have some questions :

  • Is there a general test blend file for doing a heavy load test that takes a day or so for a heavy CPU system ?
  • My system has 24 Gig of memory, i see blender is consuming greedy, but i don't know what is normal for blender Maybe if you have a test blend file, you can tell me what performance monitor counter values are normal for blender. (i think on my system it shouldnt make much use of the page file, but dll linking might cause its use i dont know how to monitor blender in perfmon on windows, i'm used to perfmon but not how blender should behave )

Getting an nvidia error means bug happens in GPU driver… so trying to use the other card could help, though embedded intel GPUs are not renown for the quality of their drivers either… You can also try to place this dll next to your blender.exe, this is software OGL, so slow as hell, but would say whether it’s really a driver bug or not.

As for ref heavy test files, that’s more a question for Cycles guys, @Thomas Dinges (dingto), any idea? Anyway, 24Go should be more than enough, unless you are rendering Avatar scenes…

Peter Boos (PGTART) added a comment.EditedOct 6 2014, 9:52 PM

Well in between video work (while i was eating) i did a render on the intel adapter, using the official release candidate of blender.

I had set my computer to use the intel video adapter (no nvidia optimalizations)..
But I dont render GPU, I render CPU so this must be main screen handling i guess. I noticed no main GUI handling slow downs or so.

The render task was a bit longer then my lunch, but i had some other work todo too.
But i noticed it didnt crash, ..so it could be that :

  • its resolved in Release version
  • it was indeed Nvidea OGL error ( looks like it, but why ?, i mean i dont render GPU )
  • my test file was to small (wasnt as large as the others, render took only about 1.5 hour. (single frame).
  • or some setting difference, this time i enabled experimental futures..all 8 cores

Keep in mind that if you are rendering with blender open you are using your GPU by definition, as blender uses OpenGL to draw.

Also if *anything* goes wrong at *any* time with your GL drivers newer windows will rescue you by reinitializing the driver. And blender does not always like this.
As you are using a laptop and rendering for extended amounts of time it is not unthinkable that you might heat up your GPU also and that can lead to these crashes in your case.

Peter Boos (PGTART) closed this task as Resolved.Oct 10 2014, 5:41 PM
Peter Boos (PGTART) claimed this task.

Now the intel drivers and the Nvidea display drivers (as i have two graphic adapters in the laptop) both got an update by windowsupdate, and i seam to be unable to reproduce the problem.

I supose that with the updates OpenGL got updated too ??, i dont know but it seams resolved now.