Page MenuHome

Lattice Transformation problem
Closed, ArchivedPublic

Description

System Information
Windows 7 Premium X64 with Intel i7 3770k and 16GB of RAM
nVidia Geforce GTX 660 Ti 2GB

Blender Version
Blender 2.72 standard release version downloaded from Blender.org download page.
Worked: never worked.

Short description of error
I tried to use lattice deform modifier to deform a simple mirrored mesh rectangular object, I did everything properly according to the tutorial and wiki page. It just won't work the way I expected it to. The mesh deforms by simply fixes the relative location of its vertices onto the closest lattice point and simplly move it along. Not only this, when I select the lattice in modifier panel, the mesh immediately enlarges itself by the size of the lattice. I have no clue what is happening. There are a handful of tutorial and problem post on the net, but I couldn't seem to find a similar case that is solved.

Exact steps for others to reproduce the error
Simply create a cube, edit it, apply the transform. (add a mirror modifier or not) Add a lattice, scale it up or down in object mode to fit it around the mesh. either apply transform on the lattice or not, add the modifier on the mesh and select the lattice just created. The problem is there. I've attached my problem-ish .blend file here. Please help!!

Details

Type
Bug

Event Timeline

Brent Lio (remotecrab131) raised the priority of this task from to Needs Triage by Developer.
Brent Lio (remotecrab131) updated the task description. (Show Details)
Brent Lio (remotecrab131) set Type to Bug.
Sergey Sharybin (sergey) closed this task as Archived.Oct 7 2014, 4:25 PM
Sergey Sharybin (sergey) claimed this task.

That's because you edited lattice in edit mode, to make the lattice fit your object you are to scale it in the object mode. It's not a blender bug, just how stuff is designed to work.

Thanks for the report, but closing it now.

That's because you edited lattice in edit mode, to make the lattice fit your object you are to scale it in the object mode. It's not a blender bug, just how stuff is designed to work.
Thanks for the report, but closing it now.

I DID NOT EDIT IT IN EDIT MODE.

What I did is only scaling it up and moved it around in object mode.

I repeat, I DID NOT EDIT IT IN EDIT MODE.

I've seen people pointing it out in some forum, but it solved none of my problem, that's why I reported it as a bug. Why would I report it as a bug when I can find solution on the internet.

Unless you are telling me that something I did would basically edit it in edit mode without me knowing or seeing it in edit mode at all.

Here is file I can't get it more simpler, but still have the problem I'm having.

I reloaded a starter scene. Added one lattice. Scaled it up in OBJECT mode. BOOM the default cube just gets bigger when I chooses the lattice object in the modifier panel.

You say this is because I edited it in edit mode. I'm not even ever in the edit mode this entire process.

I'll repost everything if this don't get noticed because it is closed.

We get notifications for closed reports. The thing is -- you're applying transform on the lattice, which is the same as if you scale it in edit mode.

We get notifications for closed reports. The thing is -- you're applying transform on the lattice, which is the same as if you scale it in edit mode.

Then you see my problem here. I did not apply transformation, I only said that in the original post that "Apply or not" either way it doesn't work.

(My bad, I actually applied transform in the original one, but still, problem exists in both situations)

The second file I provided, I did not apply the transform. but problem is there.

Here is the original one without me applying the transform. Same thing is happening and I have not find any similar situation post on the internet.

I think it happens to be problem with my other post about batch export, the scene scale, basically something around the unit of the scene is probably causing this issue.

like.. this problem I'm having feels like I created the lattice inside the mesh, and causes it to malfunction. It appears to be wrapping around my mesh, but actually because of the lattice is using a unit setting that's not calculated based on scene scale, so it is considered actually smaller or bigger when it tries to deform my mesh.
In my case, the scene scale is 0.010, so I think it actually pretends my lattice is 100 times smaller in the scene, and the lattice modifier tries to deform using the actual space instead of the visually represented size.

I don't know for sure if that is the problem.
In my batch-export problem example files, the scene scale is also 0.01, but I also have lattices in there, a lot of them, and they work fine. But it's probably because of I appended them from the original .blend file and Alt-C ed all the meshes.

https://developer.blender.org/T41931

I can make a video and find a way to show you, to demonstrate the problem, if you insist.

I apologize for sounding annoyed and angry.. lol but please, if it's a common problem that everybody already know a solution about, I would already find the solution. But because I can't get it to work by the book, and the internet seems to have not encountered this problem at all, so I reported it as a bug.

Ok, I've find some interesting information on Blender artist forum.

according to user IkariShinji, he reviewed my blender file, and found out something.

he delete the lattice I created with my PC, and he added his own lattice in the file with his PC, it was tiny, he had to scale it up 200 times to wrap around the mesh and then the lattice worked.

When I created it on my side, it was not tiny but regular sized, I only need to scale it up to2 to get it closely wrap around the mesh, but it doesn't work.

I hope this says something.

But seriously, I'm not joking here. Please take this seriously.

This is the original forum post

http://blenderartists.org/forum/showthread.php?351134-Weird-problem-I-encountered-with-lattice-modifier&p=2741042#post2741042

The only thing i could think of is the unit systems. You must have mixed steps of creating the mixed some viewport grid / unit system tweaks inbetween of object creation. So to fully understand what was wrong steps of reproducing the file you've attached here from the very scratch are needed.

The only thing i could think of is the unit systems. You must have mixed steps of creating the mixed some viewport grid / unit system tweaks inbetween of object creation. So to fully understand what was wrong steps of reproducing the file you've attached here from the very scratch are needed.

https://developer.blender.org/T42141

I'll link you to this bug report. They are the same problem but now it's getting even more complicated.