Page MenuHome

2.72 Crash on return to app.
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
iMac 27" Mid 2011
Processor: 3.4 GHz Intel Core i7
Memory: 12GB 1333MHz DDR3
Grahpics: AMD Radeon HD 6970M 2048MB

Blender Version
Broken: 2.72 (latest release)
Worked: 2.71 No issues

After working in Blender if high Density mesh (1 Million +) when I leave to browse email or other apps, on return Blender will crash. Doesn't seem tied to any action or function, just a wait period. Can't seem to duplicate it using tools. I did have Blend4Web installed but unchecked it as it wasn't supported. I do have Pie Menus running. I will try without and see if that makes a difference (If no further updates then crashes still occur).

Exact steps for others to reproduce the error
It appears to happen after I leave Blender for 5 minutes and return. First action on return will crash Blender.

I do have a crash report I can attach.

Details

Type
Bug

Event Timeline

James Allan (shamusboy) set Type to Bug.
James Allan (shamusboy) created this task.
James Allan (shamusboy) raised the priority of this task from to Needs Triage by Developer.

I would need a crashlog at least.
If i would have such problem, it would have been fixed immediately ;-)

Jens


I've uploaded/attached the crash report for you :)

I wish I could be more specific about the circumstances but it doesn't appear to be connected to any particular action. The only consistent thing is that it happens when i return to Blender if I've been checking mail or some other action. Odd.

Okay, the crashlog is worthless here, just usefiul to see exactly your specs.

Here something comes to my mind: is it wise to have a RAM configutation like yours ?
I mean the mixed 2 and 4 GB modules ? Doesn't this disturb proper paging ?

You can do a check with another memoryhungry application ( photoapp with a huge image < 4GB loaded for example )
and check if you can switch tasks without issue.

To me this does not look as a specific Blender issue atm. We have so many users without complaining about this, so
1 report is no verification here.

Sorry cannot say more atm., cannot reproduce the crashing in any case.

You can try to run blender ( binary ) in lldb to get more information.
If possible you should get/make an Blender debug build and see a more detailed log.

Jens

In case you do not know howto use lldb:

In terminal:

1: lldb <path_to_blender.app>
-> you get:

(lldb) target create "/Volumes/Workdata/Blender/Development/all_builds/x86_64_clang_omp_install/darwin/blender.app"
    Current executable set to '/Volumes/Workdata/Blender/Development/all_builds/x86_64_clang_omp_install/darwin/blender.app' (x86_64).

2: run

-> you get:

Process 955 launched: '/Volumes/Workdata/Blender/Development/all_builds/x86_64_clang_omp_install/darwin/blender.app/Contents/MacOS/blender' (x86_64)
Read new prefs: /Users/jensverwiebe/Library/Application Support/Blender/2.72/config/userpref.blend

etc.

-> try get your crash
-> if something goes wrong you will see somthing like this ( example ) :

Process 901 stopped
* thread #68: tid = 0x41336, 0x0000000101b53c01 blender`PyObject_Call(func=0x0000000117c43378, arg=0x000000011a2a46a0, kw=0x0000000000000000) + 49 at abstract.c:2065, stop reason = EXC_BAD_ACCESS (code=1, address=0x20)
    frame #0: 0x0000000101b53c01 blender`PyObject_Call(func=0x0000000117c43378, arg=0x000000011a2a46a0, kw=0x0000000000000000) + 49 at abstract.c:2065
   2062	
   2063	    if ((call = func->ob_type->tp_call) != NULL) {
   2064	        PyObject *result;
-> 2065	        if (Py_EnterRecursiveCall(" while calling a Python object"))
   2066	            return NULL;
   2067	        result = (*call)(func, arg, kw);
   2068	        Py_LeaveRecursiveCall();

-> we need this information

Jens

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.
Bastien Montagne (mont29) closed this task as Archived.Oct 16 2014, 9:09 AM

No news since one week…