Page MenuHome

An object ominously ill-affected by Cycles motion blur
Closed, ArchivedPublic

Description

System Information
W7 SP 1

Blender Version
Broken: 2.71

Short description of error

Just one object is rendered out black in cycles when motion blur is enabled. Investigated it, and found nothing out of the ordinary and/or illegal to make that happen. Stumped!!!

Exact steps for others to reproduce the error

1- Download the file from https://dl.dropboxusercontent.com/u/28170294/PL11_RV01_01.blend
2- Render a frame pressing F12
3- You'll see that the "ARM BRACELETS" object renders out black.
4- Disable motion blur and re-render
5- The material on the object correctly renders.
6- Swap the gold material with another, the result is the same.
7- You can also check out https://dl.dropboxusercontent.com/u/28170294/PL10_RV01_01.rar There the bracelets render just fine with Motion blur despite the fact that everything is the same.

Details

Type
Bug

Event Timeline

Ajlan Altug (jacobo) raised the priority of this task from to Needs Triage by Developer.
Ajlan Altug (jacobo) updated the task description. (Show Details)
Ajlan Altug (jacobo) set Type to Bug.

Correction:

The problematic file is: https://dl.dropboxusercontent.com/u/28170294/PL09_RV01_01.rar

And, motion blur goes crazy on a lot of parts on the character, not just the bracelets. You can check out the some of the frames that went bad here: https://dl.dropboxusercontent.com/u/28170294/PL09.rar

All in all, the deformation blur in cycles definitely needs looking into...

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 9 2014, 4:32 PM

Please always try with latest builds from our buildbot, 2.71 is three months old now…

Indeed, that's true. Ok... I did indeed check it out in the latest, which is 2.72, and the same thing more or less is still there. I'm rendering the scene locally, in low res and tiny dimensions, and the weird artifacts especially on the tunic the character's wearing seem to be persisting. I'm rendering on GPU's btw...

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

Sergey, another one for you I guess…

Sergey Sharybin (sergey) closed this task as Archived.Nov 18 2014, 4:55 PM

Issue with black bracelets should be fixed in 2.72b and latest builds from builder.blender.org.

Issue with tunic is caused by applying bevel modifier on top of animated geometry, which might flicker and change topology. This setup is not friendly to the deformation motion blur. You should either apply such modifiers on geometry or at least move them to the up in the modifier stack. Also make sure the cloth cache is baked.

Thanks for the report, but it seems one issue is already solve, other one is caused by unsupported setup, nothing to be fixed as fat as i can see.