Page MenuHome

Max number of channels in VSE is limited to 32
Closed, ArchivedPublic

Description

Blender Version
Broken: (example: 2.72)

Short description of error
Can't change max number of channels in VSE (it is limited to 32)

Exact steps for others to reproduce the error
I can't move my sequences in blender sequence editor higher than 31'st channel, while my setup requires much more than 32. Is there any particular reason for that, and maybe there's a way for me to build my version of blender with this fixes, any hint's where this 0..31 limit is set?
My sequence is a chalkboard on which pictures are being drawn sequentially, each drawing requires image strip, speed strip and transform strip. And I have 20 of those, so I need at least 60 channels. The only way to deal with this is to use nodes editor, by it requires too much effort for my setup, and it is not that responsive as sequence editor. I see those additional channels in window, but I can't drag any strips over them.

Details

Type
Bug

Event Timeline

Eugene Kiver (eugenekiver) raised the priority of this task from to Needs Triage by Developer.
Eugene Kiver (eugenekiver) updated the task description. (Show Details)

Well, yes, currently in code max number of channels is defined as 32 (MAXSEQ). Strictly speaking, this is not a bug, but…

I tried raising it to 256 and did a (very) quick test, everything seems OK, though…

Sergey, Antony, aware of any reason for this limitation (apart maybe performance issues, which most likely have evolved since when the limit was defined)?

PS: @Eugene Kiver (eugenekiver), if you want to try to build without that limitation, it seems defining the max number of channels you want in source/blender/makesdna/DNA_sequence_types.h, line 313 #define MAXSEQ 32 is enough. Beware though, I’d bet any file you save with strips in channels above 31 won't be compatible with official Blender builds…

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Oct 12 2014, 2:20 PM

Thanks for a hint how to fix that Bastien, I've already found another workaround, but the thing I've noticed while dealing with that, when I added 8 animated image strips and speed and transform strips to each of them, when I try to select time position at point where they all are visible at the same time, blender stops responding each time I repeat that. I also tried that on 2.71 So maybe there is a reason for that limitation. I'm using almost fresh installation of Windows 7 with powerful quad core i7 and 8 gigs of ram. So I don't think it's a memory lack issue.
I was wondering, should I upload my blend here, or should I rather create a new topic?

Sergey Sharybin (sergey) closed this task as Archived.Oct 14 2014, 10:06 AM
Sergey Sharybin (sergey) claimed this task.

Sequencer stack rendering could have O(num_channels^2) complexity so bumping the max value here might have rather negative effect. And you can always use meta strips anyway.

I don't consider this a bug. Antony might look into improving the things in sequencer to be able to render huger amount of channels in a reasonable time.

Thanks for the report, but to TODO it goes.