Page MenuHome

Blender 2.72a doesn't render with Graphic Card NVIDIA GTX 680MX
Closed, InvalidPublic

Description

System Information
Mac OSX 10.9.5 - NVIDIA GeForce GTX 680MX

Blender Version
Version 2.72a (2.72a, 2014-Oct-15, Blender

Short description of error
When I set the render type on GPU Blender give me this message: "CUDA Error out of memory..."

Exact steps for others to reproduce the error
https://www.dropbox.com/sh/et4lv5qqe78a6by/AACZXTE0MzGNhMMBe6roHXgma?dl=0

Details

Type
Bug

Related Objects

Event Timeline

Umberto Oldani (gasteropode) claimed this task.
Umberto Oldani (gasteropode) raised the priority of this task from to Needs Triage by Developer.
Umberto Oldani (gasteropode) updated the task description. (Show Details)
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.
Thomas Dinges (dingto) triaged this task as Needs Information from User priority.Oct 18 2014, 5:21 PM

Please test with the default cube, does that fail too? Probably your scene is just too large, according to Google the 680MX can have 2 GB of memory max, that might be not enough for your particular scene.

With the cube GPU it's OK, but my scene is not too large, it's a normal scene...

Thomas Dinges (dingto) closed this task as Invalid.Oct 18 2014, 6:16 PM
Thomas Dinges (dingto) claimed this task.

I tested your file on my computer now (Geforce 540M) and I can render it, but it already used ~1GB of VRAM and the file you provide is missing the world texture (which adds more Mem).

We'd like to improve memory usage in the future, but this is not considered a bug. 2GB VRAM is pretty small these days too, and you have to keep in mind that the operating system also uses VRAM, so you don't have the entire 2GB available for Blender.

No hint from me here, due i have no NVidia GFX in my MacPro atm.
I plan to get an 970 or 980 in the future to have both vendors for testing.

Jens

Let me just add that I have the exact same problem on a number of files (using 2.72b. Versions 2.72 and 2.72a have the same bug..

It is a regression bug, as these files render flawlessly and fast on ver. 2.69. I'm using Linux MInt 14, 64bit.

The files use no image textures, bit do have a hair particle system, albeit not very demading. As this occurs on virtually all files, I'm not including one here.

Do you want me to file a new bug report (with files), or can this one be reopened?

Blender 2.72 (sub 0) System Information

Blender:

version 2.72 (sub 0), branch b'master', commit date b'2014-10-21' b'11:38', hash b'9e963ae', b'Release'
build date: b'2014-10-23', b'09:26:33'
platform: b'Linux:64bit'
binary path: '/media/as/Blender/blender-2.72b-linux-glibc211-x86_64/blender'
build cflags: b'-DWITH_FREESTYLE -pipe -fPIC -funsigned-char -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -fopenmp -DNDEBUG -O2 -msse -msse2 -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN -DWITH_AUDASPACE -DWITH_AVI -DWITH_OPENNL -DHAVE_STDBOOL_H'
build cxxflags: b'-pipe -fPIC -funsigned-char -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -fopenmp -fpermissive -DSTDC_CONSTANT_MACROS -DNDEBUG -O2 -msse -msse2 -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN__ -DWITH_AUDASPACE -DWITH_AVI -DWITH_OPENNL -DHAVE_STDBOOL_H'
build linkflags: b'-lrt'

build system: b'SCons'

Blender 2.69 (sub 0) System Information

This one works:

Blender:

version 2.69 (sub 0), revision b'60991'. b'Release'
build date: b'2013-10-29', b'15:34:08'
platform: b'Linux:64bit'
binary path: '/media/as/Blender/blender-2.69-linux-glibc211-x86_64/blender'
build cflags: b'-DWITH_FREESTYLE -pipe -fPIC -funsigned-char -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -fopenmp -DNDEBUG -O2 -msse -msse2 -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN -DWITH_AUDASPACE -DWITH_AVI -DWITH_BOOL_COMPAT -DHAVE_STDBOOL_H'
build cxxflags: b'-pipe -fPIC -funsigned-char -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -fopenmp -fpermissive -DSTDC_CONSTANT_MACROS -DNDEBUG -O2 -msse -msse2 -DWITH_MOD_FLUID -DWITH_MOD_OCEANSIM -DLITTLE_ENDIAN__ -DWITH_AUDASPACE -DWITH_AVI -DWITH_BOOL_COMPAT -DHAVE_STDBOOL_H'
build linkflags: b'-lrt'
build system: b'SCons'

Python:

version: 3.3.0 (default, Nov 6 2012, 11:42:41)
[GCC 4.7.1]
paths:
'/media/as/.config/blender/2.69/scripts/addons_contrib'
'/media/as/.config/blender/2.69/scripts/addons'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/scripts/addons'
'/media/as/.config/blender/2.69/scripts/modules'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/scripts/startup'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/scripts/modules'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/python/lib/python33.zip'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/python/lib/python3.3'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/python/lib/python3.3/plat-linux'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/python/lib/python3.3/lib-dynload'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/python/lib/python3.3/site-packages'
'/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/scripts/addons/modules'
'/media/as/.config/blender/2.69/scripts/addons/modules'
'/media/as/.config/blender/2.69/scripts/addons/contour_tools/../contour_tools'

Directories:

scripts: ['/media/as/Blender/blender-2.69-linux-glibc211-x86_64/2.69/scripts', '/media/as/.config/blender/2.69/scripts']
user scripts: '/media/as/.config/blender/2.69/scripts'
pref scripts: None
datafiles: '/media/as/.config/blender/2.69/datafiles/'
config: '/media/as/.config/blender/2.69/config/'
scripts : '/media/as/.config/blender/2.69/scripts/'
autosave: '/media/as/.config/blender/2.69/autosave/'
tempdir: '/tmp/'

FFmpeg:

'avcodec':' ''54, 59, 100'
'avdevice':' ''54, 2, 101'
'avformat':' ''54, 29, 104'
'avutil':' ''51, 73, 101'
'swscale':' '' 2, 1, 101'

OpenGL

renderer: 'GeForce GTX 670/PCIe/SSE2'
vendor: 'NVIDIA Corporation'
version: '4.4.0 NVIDIA 331.38'
extensions:

		'GL_AMD_multi_draw_indirect GL_AMD_seamless_cubemap_per_texture'
		'GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_bindless_texture'
		'GL_ARB_blend_func_extended GL_ARB_buffer_storage'
		'GL_ARB_clear_buffer_object GL_ARB_clear_texture'
		'GL_ARB_color_buffer_float GL_ARB_compatibility'
		'GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth'
		'GL_ARB_compute_shader GL_ARB_compute_variable_group_size'
		'GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_debug_output'
		'GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture'
		'GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_indirect'
		'GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced'
		'GL_ARB_enhanced_layouts GL_ARB_ES2_compatibility'
		'GL_ARB_ES3_compatibility GL_ARB_explicit_attrib_location'
		'GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions'
		'GL_ARB_fragment_layer_viewport GL_ARB_fragment_program'
		'GL_ARB_fragment_program_shadow GL_ARB_fragment_shader'
		'GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object'
		'GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4'
		'GL_ARB_get_program_binary GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64'
		'GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging'
		'GL_ARB_indirect_parameters GL_ARB_instanced_arrays'
		'GL_ARB_internalformat_query GL_ARB_internalformat_query2'
		'GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment'
		'GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect'
		'GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query'
		'GL_ARB_occlusion_query2 GL_ARB_pixel_buffer_object'
		'GL_ARB_point_parameters GL_ARB_point_sprite'
		'GL_ARB_program_interface_query GL_ARB_provoking_vertex'
		'GL_ARB_robust_buffer_access_behavior GL_ARB_robustness'
		'GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map'
		'GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects'
		'GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding'
		'GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote'
		'GL_ARB_shader_image_load_store GL_ARB_shader_image_size'
		'GL_ARB_shader_objects GL_ARB_shader_precision'
		'GL_ARB_query_buffer_object GL_ARB_shader_storage_buffer_object'
		'GL_ARB_shader_subroutine GL_ARB_shader_texture_lod'
		'GL_ARB_shading_language_100 GL_ARB_shading_language_420pack'
		'GL_ARB_shading_language_include GL_ARB_shading_language_packing'
		'GL_ARB_shadow GL_ARB_stencil_texturing GL_ARB_sync'
		'GL_ARB_tessellation_shader GL_ARB_texture_border_clamp'
		'GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32'
		'GL_ARB_texture_buffer_range GL_ARB_texture_compression'
		'GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc'
		'GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array'
		'GL_ARB_texture_env_add GL_ARB_texture_env_combine'
		'GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3'
		'GL_ARB_texture_float GL_ARB_texture_gather'
		'GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat'
		'GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two'
		'GL_ARB_texture_query_levels GL_ARB_texture_query_lod'
		'GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui'
		'GL_ARB_texture_stencil8 GL_ARB_texture_storage'
		'GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle'
		'GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2'
		'GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced'
		'GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object'
		'GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object'
		'GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding'
		'GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader'
		'GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev'
		'GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers'
		'GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc'
		'GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform'
		'GL_EXT_blend_color GL_EXT_blend_equation_separate'
		'GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract'
		'GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test'
		'GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced'
		'GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit'
		'GL_EXT_framebuffer_multisample GL_EXTX_framebuffer_mixed_formats'
		'GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object'
		'GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4'
		'GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4'
		'GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil'
		'GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object'
		'GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal'
		'GL_EXT_secondary_color GL_EXT_separate_shader_objects'
		'GL_EXT_separate_specular_color GL_EXT_shader_image_load_store'
		'GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap'
		'GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object'
		'GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc'
		'GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc'
		'GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp'
		'GL_EXT_texture_env_combine GL_EXT_texture_env_dot3'
		'GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer'
		'GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp'
		'GL_EXT_texture_object GL_EXT_texture_shared_exponent'
		'GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_storage'
		'GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2'
		'GL_EXT_vertex_array GL_EXT_vertex_array_bgra'
		'GL_EXT_vertex_attrib_64bit GL_EXT_x11_sync_object'
		'GL_EXT_import_sync_object GL_IBM_rasterpos_clip'
		'GL_IBM_texture_mirrored_repeat GL_KHR_debug GL_KTX_buffer_region'
		'GL_NV_bindless_multi_draw_indirect GL_NV_bindless_texture'
		'GL_NV_blend_equation_advanced GL_NV_blend_square'
		'GL_NV_compute_program5 GL_NV_conditional_render'
		'GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float'
		'GL_NV_depth_clamp GL_NV_draw_texture GL_NV_ES1_1_compatibility'
		'GL_NV_explicit_multisample GL_NV_fence GL_NV_float_buffer'
		'GL_NV_fog_distance GL_NV_fragment_program'
		'GL_NV_fragment_program_option GL_NV_fragment_program2'
		'GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4'
		'GL_NV_gpu_program4 GL_NV_gpu_program4_1 GL_NV_gpu_program5'
		'GL_NV_gpu_program5_mem_extended GL_NV_gpu_program_fp64'
		'GL_NV_gpu_shader5 GL_NV_half_float GL_NV_light_max_exponent'
		'GL_NV_multisample_coverage GL_NV_multisample_filter_hint'
		'GL_NV_occlusion_query GL_NV_packed_depth_stencil'
		'GL_NV_parameter_buffer_object GL_NV_parameter_buffer_object2'
		'GL_NV_path_rendering GL_NV_pixel_data_range GL_NV_point_sprite'
		'GL_NV_primitive_restart GL_NV_register_combiners'
		'GL_NV_register_combiners2 GL_NV_shader_atomic_counters'
		'GL_NV_shader_atomic_float GL_NV_shader_buffer_load'
		'GL_NV_shader_storage_buffer_object GL_ARB_sparse_texture'
		'GL_NV_texgen_reflection GL_NV_texture_barrier'
		'GL_NV_texture_compression_vtc GL_NV_texture_env_combine4'
		'GL_NV_texture_expand_normal GL_NV_texture_multisample'
		'GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2'
		'GL_NV_texture_shader3 GL_NV_transform_feedback'
		'GL_NV_transform_feedback2 GL_NV_vdpau_interop GL_NV_vertex_array_range'
		'GL_NV_vertex_array_range2 GL_NV_vertex_attrib_integer_64bit'
		'GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program'
		'GL_NV_vertex_program1_1 GL_NV_vertex_program2'
		'GL_NV_vertex_program2_option GL_NV_vertex_program3'
		'GL_NVX_conditional_render GL_NVX_gpu_memory_info GL_NVX_nvenc_interop'
		'GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture'
		'GL_SGIX_shadow GL_SUN_slice_accum '
This comment was removed by André Savik (klutz).

Running out of memory is *not* considered a bug. Cycles just became more complex due to addition of deformation motion, volume etc. Of course it would be good to optimize that (and that is planned for the future), but it's not considered a bug.