Page MenuHome

Uv border edges always smooth - option for only smooth internal
Closed, ArchivedPublic

Description

System Information intel i7-3770 CPU @3.40 Ghz
Operating system and graphics card
Windows 7 64 bit, nvidia GeForce GTX 660

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen) 7.2a
Worked: (optional)NONE

Short description of error
When using a subdivision modifyer or subdividing a model, blender always smoothes border edges of uv. Other 3d application keeps border edges non smoothed and smoothes only the internal uv's of the uv island. After I've painted a texture in blender with the subdivision modifier on and then use that texture in maya, I can see areas that are not painted at the border edges

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
-create a cube
-uv unwrap it
-add a subdivision surface modifier
-apply a new texture paint slot and paint it at subdivision 3

  • go back to lowest subdivision.
  • observe the texture at the ub border edges. There are new areas visible that does not hae any paint applied to them

Details

Type
To Do

Event Timeline

Daniel Bystedt (dbystedt) set Type to Bug.
Daniel Bystedt (dbystedt) created this task.
Daniel Bystedt (dbystedt) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) closed this task as Invalid.EditedOct 20 2014, 10:53 AM

This is intended, If you want to use the UV's at a lower resolution, disable UV smoothing in the SubSurf modifier.

Hi there Campbell,

Thank you for the fast reply. I'm sorry if I was unclear in my description.

What I'm looking for is to be able to subdivide and smooth all uv's except those at the border of the uv's islands .

The reason for doing so is to be able to paint textures and lookdev in blender. As of this moment I am not able to use the textures I paint in blender within our production pipeline, since the uv's borders are smoothing. I think blender is a great application and it would be a shame not to use it.

Please let me know if you need any further explanation regarding this

Cheers
Daniel Bystedt
dbystedt.wordpress.com

Milford Film & Animation
milford.se

Hi Daniel, I can see this could be useful in some cases,

However Blender just doesn't support this, the bug tracker is to report software errors,
this is more of a feature request, which is outside the scope of the tracker.

I checked on supporting this but with the current subsurf code it doesn't work well.

OpenSubdiv integration is in development and according to @Sergey Sharybin (sergey) it can support this.

Setting TODO.

Sergey Sharybin (sergey) triaged this task as Normal priority.Oct 21 2014, 10:42 AM

Thank you for the answer. I'm really impressed by your feedback speed and transparency of the bug tracker.

Keep on doing your fantastic work.

Cheers,
Daniel