Drop to Ground add-on can not be added in Blender 2.72a
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
OS: Windows 8.1
GPU: GTX 970

Blender Version
Broken: 2.72a 73f5a41
Worked: 2.71

Short description of error
Drop to Ground add-on can not be added in Blender 2.72a

Exact steps for others to reproduce the error
Install object_drop_to_ground.py into the add-on folder
Go to user preferences -> Add ons
Select Object: Drop to Ground and check it
Returned error: AttributeError: 'RNA_Types' object has no attribute 'VIEW3D_PT_tools_objectmode'

Details

Type
Bug
Bastien Montagne (mont29) closed this task as "Invalid".Oct 19 2014, 7:24 PM

Please! This addon is not distributed with blender, so no report about it should be on our tracker.

I might have had similar problem with creaPrim addon (the same error). A new notation for location solved my issue:

old one: bpy.types.VIEW3D_PT_tools_objectmode.append(panel_ func)
new one: bpy.types.VIEW3D_PT_tools_object.append(panel_func )
better: bpy.types.VIEW3D_PT_tools_add_object.append(panel_func)

as stated in here:
http://blenderartists.org/forum/archive/index.php/t-308304.html

Working perfectly.

Thanks

BTW: Later on I have noticed that the "better:" solution performed the script without an error, but also without desired effect in Blender. The "new one:" solution worked as desired.
(Don't know the reason, I am new in Blender as well as Python)