Page MenuHome

Can't start up Blender 2.7.2.0 in Windows 7 64bit, APPCRASH MSVCR120.dll
Closed, InvalidPublic

Description

System Information
HP Z400 with 18GB Ram
Operativsystem: Windows 7 Enterprise, 64-bit (Service Pack 1)
DirectX-version: 11.0
GPU-enhetens processor: Quadro 2000
Drivrutinsversion: 340.84
Direct3D API-version: 11
Direct3D funktionsnivå: 11_0
CUDA-kärnor: 192
Kärnklocka: 625 MHz
Shaderklocka: 1251 MHz
Minnesdatahastighet: 2608 MHz
Minnesgränssnitt: 128 Bitar
Minnesbandbredd: 41.73 GB/s
Totalt tillgängligt grafikminne: 9975 MB
Dedicerat videominne: 1024 MB GDDR5
Systemvideominne: 0 MB
Delat systemminne: 8951 MB
Video BIOS-version: 70.06.3F.00.04
IRQ: Not used
Buss: PCI Express x16 Gen2
Enhets-ID: 10DE 0DD8 084A103C
Artikelnummer: 1232 0500

[Komponenter]
nvui.dll 8.17.13.4084 NVIDIA User Experience Driver Component
nvxdsync.exe 8.17.13.4084 NVIDIA User Experience Driver Component
nvxdplcy.dll 8.17.13.4084 NVIDIA User Experience Driver Component
nvxdbat.dll 8.17.13.4084 NVIDIA User Experience Driver Component
nvxdapix.dll 8.17.13.4084 NVIDIA User Experience Driver Component
NVCPL.DLL 8.17.13.4084 NVIDIA User Experience Driver Component
nvCplUIR.dll 7.8.800.0 NVIDIA Control Panel
nvCplUI.exe 7.8.800.0 NVIDIA Control Panel
nvViTvSR.dll 6.14.13.4084 NVIDIA Video Server
nvViTvS.dll 6.14.13.4084 NVIDIA Video Server
NVSTVIEW.EXE 7.17.13.4084 NVIDIA 3D Vision Photo Viewer
NVSTTEST.EXE 7.17.13.4084 NVIDIA 3D Vision Test Application
NVSTRES.DLL 7.17.13.4084 NVIDIA 3D Vision Module
nvDispSR.dll 6.14.13.4084 NVIDIA Display Server
NVMCTRAY.DLL 8.17.13.4084 NVIDIA Media Center Library
nvDispS.dll 6.14.13.4084 NVIDIA Display Server
nvWSSR.dll 6.14.13.4084 NVIDIA Workstation Server
nvWSS.dll 6.14.13.4084 NVIDIA Workstation Server
NVCUDA.DLL 8.17.13.4084 NVIDIA CUDA 6.5.18 driver
nvGameSR.dll 6.14.13.4084 NVIDIA 3D Settings Server
nvGameS.dll 6.14.13.4084 NVIDIA 3D Settings Server

Short description of error
When using the 2.7.0.0 it was python33.dll that caused the same APPCRASH, but then i also got a "Runtime Error" popup. Using 2.7.0.0 it dit not matter if i installed or using the standalone, 32 vs 64 bit - same problem.

This is from the crash-report.

Problemhändelsens namn:	APPCRASH
Programnamn:	blender.exe
Programversion:	2.7.0.0
Programtidsstämpel:	5329fcab
Namn på felmodul:	python33.dll
Modulens version:	3.3.150.1013
Tidsstämpel för felmodul:	50b3389c
Undantagskod:	40000015
Undantagsförskjutning:	000000000015796a
OS-version:	6.1.7601.2.1.0.256.4
Språkvariant-ID:	1053
Ytterligare information 1:	7909
Ytterligare information 2:	79092b5ec77af11e27b582d7007be563
Ytterligare information 3:	0589
Ytterligare information 4:	058941dd4df6fc35ca48aecf8f2ce5c8

2.7.2.0 has the MSVCR120.exe that causes the APPCRASH. I am using the stand alone version (ZIP) and I am on an enterprise environment with a "locked down" computer - I am not an administrator user and cant even change my fonts.

This is from the crash-report.

Problemhändelsens namn: APPCRASH

Programnamn:	blender-app.exe
Programversion:	2.7.2.0
Programtidsstämpel:	543ec513
Namn på felmodul:	MSVCR120.dll
Modulens version:	12.0.21005.1
Tidsstämpel för felmodul:	524f83ff
Undantagskod:	40000015
Undantagsförskjutning:	0000000000074a46
OS-version:	6.1.7601.2.1.0.256.4
Språkvariant-ID:	1053
Ytterligare information 1:	2a8f
Ytterligare information 2:	2a8f826e46538041c1c5cd9e1be3aabe
Ytterligare information 3:	4144
Ytterligare information 4:	4144b8bcb4ff62b08af727aea039ff6d

Exact steps for others to reproduce the error
Double click on blender.exe or blender-app.exe to start the application.

Details

Type
Bug

Event Timeline

Ola Hermansson (Nordlig) updated the task description. (Show Details)
Ola Hermansson (Nordlig) raised the priority of this task from to Needs Triage by Developer.
Ola Hermansson (Nordlig) set Type to Bug.

Edit: its the MSVCR120.dll (not .exe) that caused the crash according to the crash-report.

Please try with latest blender release, and ensure both your OS and drivers are fully up-to-date (and please avoid pasting such long logs in reports this way, better to attach those a text files).

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Oct 20 2014, 12:36 PM

I am using 2.7.2.0 that i downloaded today. (I wrote about 2.7.0.0 aswell as I thought it was helpful information since it is the same computer and windows environment).

Unfortunately I am using a locked down computer and are unable to update anything. I can provide you with parts of the systeminfo (DOS-command) but it seems like IE9 wont let me upload any files. Its quite long.

Bastien Montagne (mont29) closed this task as Archived.Oct 20 2014, 1:10 PM
Bastien Montagne (mont29) claimed this task.

Well, sorry, but Blender requires the latest updates for XP/Win7/Win8, else it won't work (you can thanks MS for the way they manage their building suite)… Afraid we cannot do anything else from our side.

Well I use the latest Blender 2.72a and I use Win7 SP1 and that is the latest aswell.

Operativsystemnamn: Microsoft Windows 7 Enterprise
Operativsystemsversion: 6.1.7601 Service Pack 1 Build 7601

From the syteminfo DOS-command I can provide you with a list of all the quickfixes too.

All the info in my initial post and above from my system are unfortunately with swedish titles, i know they are a bit hard to read. The first one was from my NVIDIA system report tool.

Are you absolutely shure you cant help me? You are actually my only hope to get this to work. I have googled my eyes out on this and it seems to be a rare problem. That tells me It has to be a setting made to lockdown this computer or the lockdown itself. Does Blender demand administrative access or is it my virus application F-secure that messes it up? Things like that. Does that dll-file really matter - maybe blender can be started with an attribute from DOS or something to omit that file.

Martijn, any more insight here?

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Oct 20 2014, 3:51 PM
Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.

Hi, I found some useful information in the console. It seems Blender tries to read a pythonfile from my Tribon directory. Tribon is a series of tools for constructing ships/boats.

Is it possible to make Blender read the correct file (its own file)? Maybe i need to hack the registry?

"found bundled python: C:\Temp\blender-2.71a-windows64\2.72\python
Fatal Python error: Py_Initialize: Unable to load the file system codec
File"C:\Tribon\M3\bin\python\encodings\__init__.py", line 109
raise CodecRegistryError,\
SyntaxError: invalid syntax"

Edit: I installed (ZIP) Blender on a computer without Tribon and it started up just fine.

You can try to delete "msvcr120.dll", "msvcp120.dll" and "vcomp120.dll". These files are part of the "Visual C++ Redistributable Packages for Visual Studio 2013 ".
If your system has this package installed blender will use that version instead of the local dll's

OR
you might have PYTHONPATH set as an environment variable.
You could try and run 'SET' in a cmd shell and see then 'SET PYTHONPATH=' to clear and run blender form that shell.

I deleted the dlls but it did not do it. Blender must then have found others - but they were the same ofcource. Then I tried the SET command and it clearly shows a PYTHONPATH pointed to Tribon. I will consult with CAD-support tomorrow on what this variable mean to Tribon. I hope they can coexist.

Can't wait for CAD-support so I read about SET and cleared the PYTHONPATH. The variable then dissappeared compleatly from the list of variables. Unfortunately, despite clearing variable, Blender wont start double clicking on the blender.exe giving me the same APPCRASH. But then I read your comment closer and used the cmd shell instead navigating to the blender folder and started it from there - IT WORKED. Because of the "locked down" windows enviroment I am in, everytime I reboot though the PYTHONPATH is reset so I need to work on a bat-script to set and reset the variable depending on which application I use - I guess I also need to incorporate the Blender.exe patch as well to start Blender from script.

I dont know if I want to call this a bug now when understanding the problem. I will add this as a feature request I think. There has to be several installations where PYTHONPATH is already set and Blender wont start?

Thanks for helping out.

Bastien Montagne (mont29) claimed this task.

Definitively not a bug, Blender just cannot work with a PYTHONPATH envar set to wrong py version… Thanks for the report anyway.

If you are trying to install 64 bit blender...... and facing same problem.....try 32bit blender.....works fine for me.