Page MenuHome

Collada exporter transformation "both" option is wrong
Closed, ArchivedPublic

Description

System Information
Win7, Intel

Blender Version
Broken: 2.72a, 2.71
Worked: Don't know.

Transformation type "both" for Collada exporter produces the same transformation in matrix and trans/rot/loc forms, i.e. duplicated. When parsing the Collada file and combining node transformation from all transformation elements of that node (i.e. matrix and trans/rot/loc elements) the resulting matrix seems to include the initial transformation "twice". Other transformation types "Matrix" and "TransRotLoc" works fine during export. According to Collada 1.4 spec, any combination of matrix/trans/rot/loc elements is allowed. It is not said that "either matrix or trans/rot/loc should be used if both specified".

Exact steps for others to reproduce the error
Any example which has object trans/rot/loc will show an error. Nothing fancy or specific. In my case, the Colalda node looks like this:

<matrix sid="transform">0.3712139 0.5164662 -0.2488737 0.1974505 0.9325902 -0.2160865 -0.5466911 -0.135481 -0.7532564 -0.01301114 -0.7994941 -0.2498325 0 0 0 1</matrix>
        <translate sid="location">0.1974505 -0.135481 -0.2498325</translate>
        <rotate sid="rotationZ">0 0 1 -111.7048</rotate>
        <rotate sid="rotationY">0 1 0 143.114</rotate>
        <rotate sid="rotationX">1 0 0 1.66461</rotate>
        <scale sid="scale">1.254958 0.56 1</scale>

As seen, translation and in the matrix element matches with the translation in the separate element, i.e. duplicated. The same is with angles and scaling.

Details

Type
Bug

Event Timeline

Andrejs Hanins (hashok) raised the priority of this task from to Needs Triage by Developer.
Andrejs Hanins (hashok) updated the task description. (Show Details)
Andrejs Hanins (hashok) set Type to Bug.
Sergey Sharybin (sergey) closed this task as Archived.Oct 21 2014, 10:14 AM
Sergey Sharybin (sergey) claimed this task.

We don't currently have collada maintainer, so thanks for the report but moving it to the todo list: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export#Export:_Bugs