Page MenuHome

Is this related???
Closed, ArchivedPublic

Description

OK... I have no idea what I'm doing here guys and girls... If im in the wrong place, or stepping on toes sorry and please help...
The image explains the issue.
I've added the blender doc.

I'm on Windows 8.1 x64, Intel(R) Core(TM) i7-3610QM CPU @ 2.30 GHz, NVIDIA GeForce GT 630M

Details

Type
Bug

Event Timeline

David Purton (viceverser) updated the task description. (Show Details)
David Purton (viceverser) raised the priority of this task from to Needs Triage by Developer.
David Purton (viceverser) set Type to Bug.

I've tried it on Blender 2.72a and 2.72b{F119769}

Could you add an example blend file for testing it?

{F119775}I've tried it on Blender 2.72a and 2.72b{F119769}

sorry for the zip files, but i kept having issues with file size upload... that was the only workaround i could think of.

@David Purton (viceverser) you could have put the file on some file sharing site like https://dropbox.com. Just a note for next time :)

@David Purton (viceverser) you could have put the file on some file sharing site like https://dropbox.com. Just a note for next time :)

Thanks Kevin... Will do next time :)

Hi, joining these files isn't really working for us (002 is missing too). please upload the file externally if the tracker fails for some reason

I've removed all objects and kept the materials, added cube.

Select cube, go to materials and in drop down, the materials choice comes up then crashes.

If you save the blend before the crash, and bring it up again, the material will not be there.

Okay, reduced it further.
Open attached .blend
On the cube, attach the diffuse to the mix shader, (SSS is already connected), crash.

Blend file here:

https://dl.dropboxusercontent.com/u/8938212/modellingSculptbug2.blend

and crash report below.

edit:
Actually, just on new blend on cube, add diffuse, SSS, mix and with material panel open, connect them. I think we had this issue before, it was something about material preview and a race condition. T40800

Sergey, another issue with material preview, does this look like similar problem as was fixed in T40800?

Wasn't able to reproduce this here. Could you try with the latest build from https://builder.blender.org/download/?
Thanks for reporting @David Purton (viceverser)

Here's a video of what's causing this file to crash.
SSS to mix shader with material preview open.
This is with latest build from build bot 10/29/14

http://youtu.be/7JClYqQpEAA

Still not able to reproduce this on linux 64 bit. Could you have a look on it @Sergey Sharybin (sergey)?

Just tested this on Windows 7 and OSX 10.8.5. On OSX I do have the crash on Windows 7 I'm unable to reproduce it. (Also tried on Linux under Virtual Box on OSX and also no crash.)

Bastien Montagne (mont29) triaged this task as Normal priority.Oct 31 2014, 9:42 AM
Brecht Van Lommel (brecht) closed this task as Archived.Nov 9 2014, 3:45 AM

There's two different issues reported here, and both of them are related to the use of Open Shading Language. The subsurface scattering crash is a duplicate of T42210, and the original report is a duplicate of T41966, which is about image textures crashing in windows 8.