Page MenuHome

Volumetric Material appears wrong in Rendered Viewport Shading
Closed, InvalidPublic

Description


System Information
Win 7 64bit, Radeon HD 6850

Blender Version
tested in 2.72a & 2.72b

Short description of error
Volumetric Material appears wrong in Rendered Viewport Shading when World Background is black (0,0,0)

Exact steps for others to reproduce the error
Probably the World Background need to be black to reproduce this bug.
Possibly also a scene with black World Background Color must be saved as default startup file in advance.

Switch to Cycles Render Engine
Delete the default Cube and Lamp.
Add a UV Sphere, unwrapp it, add Diffuse Material, add UV mapped Image Texture to the Diffuse Color Input, set the Object to be Shaded Smooth.
Add an Ico Shere to same position as the UV Sphere is, scale the Ico Sphere slightly larger than the UV Sphere is, add a Volumetric Scatter Material, set the Ico to Shaded Smooth.
Add a Sun Lamp, turn Multiple Importance Sample on.
Switch the Viewport Shading to Rendered.
If the Volumetric Scatter Material appears wrong now somehow (like in the attachement / lower left image) go to the World Buttons
and change the Background Color to any brighter than black(0,0,0). If the Material appears correctly now it should stay like this even
if you change the Background Color to black again.

Greetings Martin

Details

Type
Bug

Event Timeline

martin me (martinme) set Type to Bug.
martin me (martinme) created this task.
martin me (martinme) raised the priority of this task from to Needs Triage by Developer.

Can you attach a blend file of when it appears wrong?
I can't reproduce on OS X.

martin me (martinme) added a comment.EditedOct 27 2014, 3:07 AM

It's a mystery !
I can't find a reliable way to reproduce this bug by myself now.
I was able to reproduce it once again now, but when I just moved the Render Camera it disappeared / rendered correctly.
I tried to reproduce it serveral times afterwards but failed.
I had this bug the first time 2 days ago and then it was also hard to reproduce. For sure it is not reproducable within
the same Blender session, when it ones rendered correctly before. Possible I also may need to restart my PC - but I just don't tried that.

I may try it again in the next days. For now I'm a bit unstrung and tired. ;)

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Well, without a way to reproduce it, or at least a .blend file showing the bug, we can’t do much.

Thomas Dinges (dingto) closed this task as Invalid.Nov 3 2014, 7:04 AM
Thomas Dinges (dingto) claimed this task.

No blend file, no way to check..