Page MenuHome

HDR image thumbnails cause blender to crash
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 7 64 bit Graphics card: nvidea gtx 660 ti

Blender Version
Broken: 2.72 6c2ce7a and official blender 2.72b

Error Description: When viewing hdr images in the file browser with thumbnails enabled blender will crash. When an hdr is opened using the list view, opening the "browse image to be linked" drop down will crash blender.

Exact steps for others to reproduce the error
Open new scene. Assign environment texture to world. Click open and change file display mode to thumbnails. Open a folder with an hdr image. Blender will crash.

If an hdr is loaded by not using the thumbnail preview mode then anytime the image datablock drop down menu is opened blender will crash.

Event Timeline

Daniel Stokes (danielstokes) raised the priority of this task from to Needs Triage by Developer.
Daniel Stokes (danielstokes) updated the task description. (Show Details)

cannot confirm, working fine here (linux).
maybe it's the specific file? (e.g. do the HDRs from openfootage.net work?)

Campbell Barton (campbellbarton) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 28 2014, 9:59 AM

Please find the HDR file causing the crash and link to it.

Tested on 2.72 and 2.72b on macosx 10.10: no problem, working fine too.

I tried again with an HDR from openfootage and it didn't crash. I think it is related to the file size because all the HDRs that were crashing on my computer were 30 MiB and upwards.

Just tried with 180MB HDR: no crash
however: this one did not get a preview image generated (plain document icon instead)

I opened the affected HDRs in photoshop and they were partially corrupted. I never noticed because if blender didn't crash when opening them then in the render they looked fine. Thank you for your help. Sorry for wasting your time.

@Philipp Oeser (lichtwerk): above 100 Mb no preview icons get generated

@Daniel Stokes (danielstokes): could you still link one of those corrupted files? Even if they are corrupted, I don't think Blender should crash.

Bastien Montagne (mont29) closed this task as Archived.Nov 7 2014, 9:13 AM
Bastien Montagne (mont29) claimed this task.

Let’s close that for until requested data are provided…

I can confirm the segfault here on linux 64 with rB5674ac9.

Some quick backtrace:

This also happens if you manage to load the image in e.g. an image texture node in Cycles and switch to Material view (preview and final render are fine).
Kévin Dietrich (kevindietrich) raised the priority of this task from Needs Information from User to Confirmed, Medium.Nov 17 2014, 8:07 PM

Hrrmmmm… We read way too much data somehow here, this file is 8192 × 3153 for 45MB (which rather low, but its lower part can probably be compressed quite heavily even with RLE), and we overrun at line 1974: reading line 1974 starting at 42.882545MB from file start!

Note the file itself is valid afaict (imagemagick opens it e.g.).

Bastien Montagne (mont29) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Nov 21 2014, 10:34 AM

Grmlll… a (very rough) estimation says me this file should be around 75MB anyway… :/

Can you please give us application used to generate this HDR (comment says Blender???)? With parameters used, too…

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Nov 21 2014, 11:50 AM

OK, so can confirm this file is definitively invalid (truncated, actually).

Will add some safeguard code to avoid crashing in such cases, nicer anyway.