Page MenuHome

Material ID pass from Cycles contains wrong samples (pixels)
Closed, ArchivedPublic

Description

System Information
OS X 10.8.5 (12F45) - NVIDIA GeForce GT 650M 1024 MB
Windows 7 Professional (with SP1) - ATI FirePro V7800 (FireGL V)
Linux Mint 16 KDE - ATI FirePro V7800 (FireGL V)

Blender Version
Broken:
OSX: 2.72.1 409b3c9; 2.72.0 95182d1
Windows 7: 2.72.1 beaed66
Working:
Linux: 2.71.0 9337574; 2.72.1 beaed66

Short description of error
When rendering the material ID of an objects which has thickness and a different material for the inside and the outside, sometimes some pixels give the wrong material ID. I tried both with CPU and GPU rendering and got the same problem, just different pixels.
When I render the same scene with Blender Internal it works fine. Also the problem seems only to be affecting Blender when running on OSX or Windows, on Linux I can't reproduce the bug.

Exact steps for others to reproduce the error
Open the .blend file and press render. In the image viewer the wrong pixels are marked with the grease pencil (if you load with 'keep UI') (they were on the same place on different computers for me). On layer 1 the object still has the modifiers on layer 2 the modifiers are applied. Both have exactly the same behavior.
In the compositor you can switch between ID 1 and 2 to see the same problem for both materials.

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) closed this task as Archived.Nov 4 2014, 6:10 PM

This is a precision issue by the looks of it. Using watertight ray/tri intersection avoids this artifacts. We've got patch for this, but we still need to solve issued before we can commit it.

Thanks for the report, but for now it's a TODO.