Page MenuHome

Infinite Zoom
Closed, ResolvedPublic

Description

System Information
Windows 8.0 and intel graphics 4600

Blender Version
Broken: 2.72b (9e963ae)
Worked: (optional)

Short description of error
Within the sequencer in preview allows you to zoom forever
creating a very jagged result witch is not needed the super large pixels is more then good

Exact steps for others to reproduce the error

  1. Place a image strip in the sequencer
  2. Go to the preview and zoom in and keep zoom after you get the huge pixels

Event Timeline

Aaron Carlisle (Blendify) set Type to Bug.
Aaron Carlisle (Blendify) created this task.
Aaron Carlisle (Blendify) raised the priority of this task from to Needs Triage by Developer.

Here Is a image of what will happen

and you can zoom in more then that

Julian Eisel (Severin) closed this task as Invalid.

Hey @Aaron Carlisle (Blendify),
I don't see a need for a fix here. Having no limits isn't a bad thing mostly ;).

Furthermore, I'd like to adress a couple of things in this report:

  • If you don't really know the active Blender developers and who's responsible for which part of Blender, don't assign bugs by yourself. Especially, you shouldn't assign bugs to Ton, as he currently isn't able to code for Blender or fix Bugs at all, there are other people doing this. I'm also not sure why you reassigned it to jonata, who doesn't seem to be an active Developer fixing Bugs (if you've talked to him previously and he offered himself to look into this it's okay, though)
  • You shouldn't add projects on your own (also, as long as you don't really know what you're doing).

Just follow the guide here and let us do the rest. "You do your half of the work, then we do our half!", that's the deal.
That's already it. so, please make sure to don't do the things stated above the next time.

But nevertheless, thanks for the report @Aaron Carlisle (Blendify), but no real bug here :)

Hello. I am not an active developer, I am just a user who sends bugs and bothers the developers a bit :D

hey sorry this is my first bug report
a couple of things one the bug
it only happened in the sequencer, not in the image editor, and you can zoom in for hour then spend the same time amount of time undoing it. i did not confirm this however it will turn to the color of the background.

Note: seems that sequencer limits aren't enforced:

This change however only applies to newly created spaces, needs a do-versions too to update existing files.

1diff --git a/source/blender/editors/space_sequencer/space_sequencer.c b/source/blender/editors/space_sequencer/space_sequencer.c
2index c0cfaed..f97344f 100644
3--- a/source/blender/editors/space_sequencer/space_sequencer.c
4+++ b/source/blender/editors/space_sequencer/space_sequencer.c
5@@ -144,7 +144,7 @@ static SpaceLink *sequencer_new(const bContext *C)
6 ar->alignment = RGN_ALIGN_TOP;
7 ar->flag |= RGN_FLAG_HIDDEN;
8 /* for now, aspect ratio should be maintained, and zoom is clamped within sane default limits */
9- ar->v2d.keepzoom = V2D_KEEPASPECT | V2D_KEEPZOOM;
10+ ar->v2d.keepzoom = V2D_KEEPASPECT | V2D_KEEPZOOM | V2D_LIMITZOOM;
11 ar->v2d.minzoom = 0.00001f;
12 ar->v2d.maxzoom = 100000.0f;
13 ar->v2d.tot.xmin = -960.0f; /* 1920 width centered */

Okay, should be an easy fix. Can have a look at it later.

This could be set as todo, its not really much of a problem

be sure to check this fix works for split-screen preview too.

Julian Eisel (Severin) triaged this task as Normal priority.Nov 6 2014, 11:57 AM

I don't no exactly how this "bit" of code works but make sure that it will apply itself to the other previews such as the Vetro-Scope waveform and histogram.

Campbell Barton (campbellbarton) raised the priority of this task from Normal to Confirmed, Medium.

Setting as todo, this isn't really preventing anyone from using the zoom operator.

Don't think this is a quick hack, its a very small change but needs to be done carefully and test with file versioning.

This is fixed 25%

see picture

(Nota Bene: This Picture is of two pixels next to each other zoomed to really far)

The zoom limits should be somewhere like that of the image editor

Limits should be more sane now.

still does not work?

Linux build afa8a0a

It "works" fine, it is not really important does not stop anyone from working and we have much more important things to look at.

is it a reasonable option to keep this as a todo since pixels start to look like multiple pixels